cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
martincamp
Observer
Observer
1,174 Views
Registered: ‎01-22-2019

System generator license checkout failed

Jump to solution

We purchased Vivado sytem edition on 7/9/19.  Installed license and everyting worked fine.  Now I can run models, but when I generate I get the following in the error log:

Summary of Errors:
Error 0001: Sysgen license checkout failed.
XILINXD_LICENSE_FILE = C...
Block: Unspecified
--------------------------------------------------------------------------------

Error 0001:

Reported by:
Unspecified

Details:
Sysgen license checkout failed.
XILINXD_LICENSE_FILE = C:\Xilinx\xilinx.lic;C:/Xilinx/Vivado/2018.3/data/sysgen/hwcosim_compiler/pp_ethernet
LM_LICENSE_FILE = C:/modelsim_dlx_10.2b/satpath.txt;C:\modelsim_dlx_10.2b\Site_3116454.txt
License search path: C:\Users\martinc\AppData\Roaming\XilinxLicense;C:\.Xilinx;C:\Xilinx\xilinx.lic;C:\Xilinx\Vivado\2018.3\data\sysgen\hwcosim_compiler\pp_ethernet;C:\modelsim_dlx_10.2b\satpath.txt;C:\modelsim_dlx_10.2b\Site_3116454.txt;C:\Xilinx\Vivado\2018.3\data\ipcore_licenses

--------------------------------------------------------------------------------

 

I attached the license file and env.txt here for review.  Thanks.

0 Kudos
1 Solution

Accepted Solutions
martincamp
Observer
Observer
924 Views
Registered: ‎01-22-2019

There apparently was some problem with the formatting of the license file.  I just copied the text out of the original file into a new file and saved it and now the license works.

View solution in original post

13 Replies
graces
Moderator
Moderator
1,129 Views
Registered: ‎07-16-2008

From the env.txt, there're only 30-day trial license (expired) and WebPACK license for tools feature. The system edition license doesn't seem to be correctly set up.

I see you set XILINXD_LICENSE_FILE to C:\Xilinx\xilinx.lic. If you place the license file in this directory, pay attention to the upper/lower case in file name.

-----------------------------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs.
-----------------------------------------------------------------------------------------------------------------------
0 Kudos
martincamp
Observer
Observer
1,117 Views
Registered: ‎01-22-2019

I changed the environment variable to match the case.  It still doesn't work.  When I load the license in the Vivado license manager I don't see the my licenses.  Why would that be?

0 Kudos
graces
Moderator
Moderator
1,099 Views
Registered: ‎07-16-2008

After changing the environment variable, did you restart sysgen/license manager in the same terminal?

Also try to remove the trial and webpack license files.

-----------------------------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs.
-----------------------------------------------------------------------------------------------------------------------
0 Kudos
martincamp
Observer
Observer
1,090 Views
Registered: ‎01-22-2019

Yes, I restarted after changing the environment variable.  deleting the trial and webpack licenses did not help.

0 Kudos
graces
Moderator
Moderator
1,071 Views
Registered: ‎07-16-2008

With the trial and webpack licenses cleared, would you please run "report_environment -file env.txt" from Vivado Tcl and provide the exported file?

Also try to run the following command from command line and see what it returns.

lmutil lmdiag SysGen -c C:\Xilinx\Xilinx.lic

-----------------------------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs.
-----------------------------------------------------------------------------------------------------------------------
0 Kudos
martincamp
Observer
Observer
1,061 Views
Registered: ‎01-22-2019

It doesn't see the license in my file.  Here is the output:

C:\Users\martinc>lmutil lmdiag SysGen -c C:\Xilinx\xilinx.lic
lmutil - Copyright (c) 1989-2003 by Macrovision Corporation. All rights reserved.
FLEXlm diagnostics on Wed 8/28/2019 07:19

-----------------------------------------------------
License file: C:\Xilinx\xilinx.lic
-----------------------------------------------------
No licenses for SysGen in this license file

 

env.txt is attached.

0 Kudos
graces
Moderator
Moderator
1,042 Views
Registered: ‎07-16-2008

It looks you license management tools (lmutil) are out of date.

Vivado 2017.3 and later versions require upgrading your license server tools to the Flex 11.14.1 versions.

-----------------------------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs.
-----------------------------------------------------------------------------------------------------------------------
0 Kudos
martincamp
Observer
Observer
1,026 Views
Registered: ‎01-22-2019

The newer lmutil returns the same message:

C:\Xilinx\windows_flexlm_v11.14.1.0\win64.o>lmutil lmdiag SysGen -c c:\Xilinx\xilinx.lic
lmutil - Copyright (c) 1989-2016 Flexera Software LLC. All Rights Reserved.
FlexNet diagnostics on Thu 8/29/2019 07:36

-----------------------------------------------------
License file: c:\Xilinx\xilinx.lic
-----------------------------------------------------
No licenses for SysGen in this license file

 

Since this is a node locked license I thought the flexlm was not needed.

0 Kudos
martincamp
Observer
Observer
1,020 Views
Registered: ‎01-22-2019

I will be out of the office Friday and Monday is a holiday so I won't be able to work on this until next Tuesday.  I need this issue to be resolved quickly since I cannot continue my work. 

0 Kudos
graces
Moderator
Moderator
961 Views
Registered: ‎07-16-2008

The license file looks fine. Not sure why Sysgen feature is not checked out.

Can the other features be detected successfully?

lmutil lmdiag Synthesis -c C:\Xilinx\Xilinx.lic

Does it make any difference if you copy the license file to the default search directory C:\.Xilinx (note the dot before Xilinx)?

-----------------------------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs.
-----------------------------------------------------------------------------------------------------------------------
0 Kudos
anatoli
Moderator
Moderator
952 Views
Registered: ‎06-14-2010

Hello @martincamp ,

It seems you have a license file called Xilinx.lic.txt instead of Xilinx.lic (a LIC file extension).

I've seen this happening when the File Name Extension in the view panel (on Windows OS) isn't selected. Therefore, if you manually change the name of the license file from Xilinx to Xilinx.lic, if the file file was originally a .txt file, however since the File Name extension option wasn't selected, that means you've actually renamed this file to Xilinx.lic.txt file instead.

Therefore, please navigate to the folder where you've put your lic file and under the View, please select/tick "File Name extensions" as shown below.

image.png

Then please see if the file is actually Xilinx.lic or Xilinx.lic.txt?

Alternatively, you should see the extension as LIC File as shown below.

image.png

 

Do you see LIC File or TXT File?

 image.png

The above example was taken when I had no File Name extension selected.
As you can see in the above example, you'd assume this is a Xilinx.lic file, however since the File Name Extension option isn't selected, the file is actually a TXT file (i.e. Xilinx.lic.txt) and Vivado won't be able to detect this file, as in reality the file extension is as follows:

image.png

I've seen this cause a licensing issue for other users. Therefore, can you please double check on this too, as to me, since your OS is also a Windows related OS, that could be the root cause of your licensing issue.

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos
martincamp
Observer
Observer
925 Views
Registered: ‎01-22-2019

There apparently was some problem with the formatting of the license file.  I just copied the text out of the original file into a new file and saved it and now the license works.

View solution in original post

anatoli
Moderator
Moderator
920 Views
Registered: ‎06-14-2010

Hello @martincamp ,

Excellent news and thanks a lot for letting us know. Glad that you've managed to overcome this issue.

As your issue is resolved now and if there are no further questions, can you please mark a response as Accepted Solution (more info on this can be found here: https://forums.xilinx.com/t5/help/faqpage/faq-category-id/solutions#solutions), so that the topic can be completed then?  We appreciate your help.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos