cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
415 Views
Registered: ‎08-10-2020

[VITIS] Installation on Ubuntu 18.04.05 fails due to Java Exception

Jump to solution

Hello,

When executing the .bin file downloaded from https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/vitis.html

an alert Image is shown saying that this Linux version is not directly supported but one can continue anyways. In the background one can already see that the installer is opened.

kevinkit_0-1597129274109.png


However in the terminal the following error message is shown:

Exception in thread "SPLASH_LOAD_MESSAGE" java.lang.IllegalStateException: no splash screen available
at java.desktop/java.awt.SplashScreen.checkVisible(Unknown Source)
at java.desktop/java.awt.SplashScreen.getBounds(Unknown Source)
at java.desktop/java.awt.SplashScreen.getSize(Unknown Source)
at com.xilinx.installer.gui.H.run(Unknown Source)

which makes the installation on the Ubuntu version impossible.

Any solutions to this?

 

Greetings,

Kevin

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
329 Views
Registered: ‎12-04-2019

Hi @kevinkit ,

Please go through below forum discussion and check if it helps.

https://forums.xilinx.com/t5/Installation-and-Licensing/Installation-of-Vivado-2020-1-under-Centos-7-8-fails/td-p/1115482

 

Thanks and Regards,

Ansari Hunen

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as a solution.
-------------------------------------------------------------------------

View solution in original post

4 Replies
Highlighted
Xilinx Employee
Xilinx Employee
330 Views
Registered: ‎12-04-2019

Hi @kevinkit ,

Please go through below forum discussion and check if it helps.

https://forums.xilinx.com/t5/Installation-and-Licensing/Installation-of-Vivado-2020-1-under-Centos-7-8-fails/td-p/1115482

 

Thanks and Regards,

Ansari Hunen

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as a solution.
-------------------------------------------------------------------------

View solution in original post

Highlighted
Visitor
Visitor
314 Views
Registered: ‎08-10-2020

Thanks, it helped - however not supporting a minor version change is strange (18.04.04 is supported, 18.04.05 is not)

Greetings

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
279 Views
Registered: ‎12-04-2019

Hi @kevinkit ,

Good to know that it helped you to solve the issue.

Please let us know if you need any further assistance in relation to this topic or else close this thread by accepting it as a solution so that it can help others.

 

Thanks and Regards,

Ansari Hunen

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as a solution.
-------------------------------------------------------------------------

0 Kudos
Highlighted
Visitor
Visitor
46 Views
Registered: ‎08-10-2020

This should be closed when the bug is fixed not when a workarond makes it somehow work imho

0 Kudos