cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jcfox
Visitor
Visitor
5,250 Views
Registered: ‎08-03-2017

Vivado 2017.4 failure to launch/time out

Jump to solution

 

Hello,

 

I am trying to upgrade Vivado to 2017.4 but am having problems after launching Vivado. I did a web installation and everything seemed to install properly with no errors being returned. I also loaded my license with no issues as well. The problem is that after Vivado is launched, no splash screen loads up and after a couple of minutes the Launcher throws an error saying it has timed out. "Error when launching C:\PATH_TO_VIVADO\vivado.bat: Launcher timed out"

 

I have also tried launching vivado using tcl which launches just fine until I try to execute "start_gui". I have attached an image of what happens.

 

The system running Vivado is a Windows 10 Pro machine using version 1709 (Fall Creators Update).

 

Any idea where to go from here would be highly appreciated, thank you.

 

jcfox

error.png
0 Kudos
1 Solution

Accepted Solutions
anatoli
Moderator
Moderator
6,146 Views
Registered: ‎06-14-2010

Hello @jcfox,

 

 

Apologies, I was out until today and couldn’t respond any sooner.

 

Are there any updates regarding this issue? Were you able to overcome this issue yet?

 

To me, the issue is something to do with the Fall Creator Update. I'm out of ideas why this is happening at your machine.

Would you have access to a different host running Win10 Fall Creators Update? If so, can you please check and see if the problem reproduces there?

 

As a suggestion, you can also try uninstalling Fall Creators Update by following these steps:

 

This is documented here: https://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install-winpc/how-to-use-the-rollback-function-in-windows-10/3e9e5c2d-239f-488c-9f48-64a226302657

 

With Windows 10, it seems Microsoft has listened and has provided a welcome option to its recovery tools to make it easy to uninstall Windows 10 latest update and go back to your previous version of Windows 10. 

 

To uninstall the Fall Creators Update, go to Start > Settings and click on Update & Security.

Click the Recovery link on the left and then click on Get started under 'Go back to the previous version of Windows 10.'

 

That way you should be able to revert back to Win 10 1703 (Creator Update). 2017.4 is supported on this OS (means that we (Xilinx) has tested 2017.4 on Creators update, where as with 2017.4 and Fall Creators Update, only some limited tests were performed), so you shouldn't see this issue then.

 

Can you give this a try and see if you'd get a better outcome?

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------

View solution in original post

24 Replies
5,227 Views
Registered: ‎01-22-2015

I had a similar problem when upgrading to Vivado v2017.3.  The solution proposed by @bandi in <this post> worked for me.

 

Mark

0 Kudos
jcfox
Visitor
Visitor
5,221 Views
Registered: ‎08-03-2017

markg@prosensing.com

 

Thank you for your response, unfortunately this fix did not work for me. It seems like "'vivado-vg.exedoes not exist anymore. There is a "vivado-sh.exe" so I tried using that instead and applying the fix you suggested.

 

When I did so I received several errors regarding .dll(s) missing (libboost_signals, librdi_common, SHSMP64, and librdi_commonmain). From here I thought that I would just include the lib directory inside vivado and insert it into the system path and see if that resolved these missing dependencies but when I do so the program fails to execute and immediately crashes reporting "Error: The file  is corrupt. Please re-install this software from the original media."

 

Thank you for response though,

jcfox

 

0 Kudos
bandi
Moderator
Moderator
5,187 Views
Registered: ‎09-15-2016

Hi @jcfox,

 

Can you please refer the below Answer Records and check if it helps:

 

https://www.xilinx.com/support/answers/57386.html

https://www.xilinx.com/support/answers/69076.html

 

Please make sure that Microsoft Visual C++ 2015 redistributables are installed in your machine.
Please share the xinstall.log, located at c:/Users/user_name/.Xilinx/xinstall/

 

Thanks & Regards,

Sravanthi B

Thanks & Regards,
Sravanthi B
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
jcfox
Visitor
Visitor
5,168 Views
Registered: ‎08-03-2017

Hello @bandi,

 

I checked to see what version of the redistributables I was running on the system and I can see that I am running a later version than what was provided in the Vivado installation (currently running 14.0.24215 in both x86 and x64). I also tried some of the other fixes suggested in the ARs but still haven't had any luck on successfully launching vivado.

 

I don't see anything obvious about missing anything or throwing an error that is provided in the log but I may be blind.

 

Thank you again,

jcfox

0 Kudos
anatoli
Moderator
Moderator
5,039 Views
Registered: ‎06-14-2010

Hello @jcfox,

 

Based on your log file, the installation seems to be completed successfully and nothing is wrong from the install point of view.

 

However, it does look like a Java specific error/issue and due to this, the Vivado GUI can't be started. 

Can you please confirm if 2015 Microsoft redistributables have been installed on this particular machine? Vivado 2017.x requires vcredist 2015 to be installed.

 

To check this, please go to the  "Control Panel", and then to Programs and Features and in here, see if you can see "Microsoft Visual C++ 2015 Redistributable (x64 and x86)" (i.e. vcredist 2015). If so, then it is installed correctly. However, if you have a newer version like Microsoft Visual C++ 2017 Redistributable , try uninstalling vcredist 2017 and then installing  vcredist 2015. 

You can obtain the redistributables from Microsoft:

https://www.microsoft.com/en-us/download/details.aspx?id=48145

 

Then check again under Programs and Features, so make sure Microsoft Visual C++ 2015 Redistributable (x64 and x86) have been applied correctly and then try the installation process again.

 

If 2015 Microsoft redistributables have been installed on this machine, can you please try bypassing the vcredist check with/by setting this environment variable:

XIL_PA_NO_REDIST_CHECK = 1

 

….and then see if you still seeing the same behaviour or not?

 

Please let me know if you have any questions on the above.

 

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos
jcfox
Visitor
Visitor
5,028 Views
Registered: ‎08-03-2017

Hello @anatoli,

 

Thank you for your response! Unfortunately I am still seeing the same error in my first post after the fix you suggested.

 

Right now the system is currently using Microsoft Visual C++ 2015 as the most recent version. I went an extra step further and actually uninstalled the previous vcredist and redownloaded a fresh install from the Microsoft link you provided. In addition I also tried adding XIL_PA_NO_REDIST_CHECK = 1 to the system environmental variables as you suggested but this also did not work.

 

I have also looked to see if I have the most up to date version of Java installed on the system and as of now Java is reporting that everything is up to date.

 

Again thank you for your response,

jcfox

0 Kudos
anatoli
Moderator
Moderator
5,010 Views
Registered: ‎06-14-2010

Hello @jcfox,

 

Can you please clarify a few things that could help to narrow down the issue to see if this is a Vivado installation issue or a Vivado GUI related problem?

 

  • Can you please double check and see if any other Vivado (Java-dependant) tools can be opened at your end? Try opening a Vivado License Manager (VLM), SDK, model composer, or other Xilinx tools to see if the same issue happens?
  • In batch tcl mode, I know you can’t open Vivado GUI using this start_gui tcl command, however, can you please try other batch mode commands, such as opening a design in batch mode rather than in the Vivado GUI mode, and then see if you see any issues/errors then or not? Just need to make sure the issue is only with the GUI, but it still lets you to work with your design in the batch mode.
  • In the original notes you have stated that you are trying to upgrade to 2017.4 and now seeing issues, therefore, can you clarify the following please:
  • a) Did you have any other Vivado tools installed prior to 2017.4, such as 2017.3 for example, on this specific OS (with Falls Creator Update) and everything worked fine until you’ve installed Vivado 2017.4?
  • b) Or, perhaps, you did have 2017.3, but the Falls Creator Update was not applied at the time and your OS was Win 10 1607 (Anniversary Edition) or Creators Update 1703, and everything worked fine. However, since Falls Creator Update was applied, your Vivado 2017.3 has stopped working and that is when you went ahead and obtained and installed Vivado 2017.4 and now Vivado can’t be opened either and you have then raised this issue?

 

 

Can you confirm on the above please? Thanks

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos
jcfox
Visitor
Visitor
4,997 Views
Registered: ‎08-03-2017

Hello again @anatoli,

 

  • I have tested Vivado License Manager, Vivado HLS, and SDK that was installed with Vivado and all seem to be working fine.
  • I'm not too familiar with using TCL batch mode but I was able to create a new project and import files into the project just fine.

As for the third point:

  • I did have Vivado 2017.3 prior to me updating to 2017.4.
  • 2017.3 was running fine with the Creators Update for Windows 10 (1703). Once Windows updated to the Fall Creator Update Vivado 2017.3 stopped working all together. At the time I had also posted another thread here about the issues I was having (very similar to the current problems I am having now) and tried a few fixes recommended in the AR and user's posts. Unfortunately none of the fixes worked back then so I waited for the new release of Vivado. I decided to open a new thread up again since some of the symptoms changed and also I had moved away from 2017.3. Before I updated Vivado to 2017.4, I made sure to remove all the previous version's installation files/directories to make sure there would not be any version conflicts.

 

I have to applaud your sharp eye for pretty much describing the exact situation I am in with your last point!

 

Thank you again for your response,

jcfox

0 Kudos
anatoli
Moderator
Moderator
4,991 Views
Registered: ‎06-14-2010

Hello @jcfox,

 

I'm currently working with the development team to see what can be done in this situation, as to me, I've tied to reproduce the issue at my end using the Win10 Fall Creators Update wand I have no issues opening the 2017.4 Vivado GUI.

 

One more check please, can you share your PATH environment variable, for examination? I just need to check and see what it is pointing to and compare this with my PATH on this Win10 Fall Creators Update machine. 

 

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos
jcfox
Visitor
Visitor
4,279 Views
Registered: ‎08-03-2017

@anatoli,

 

Here is a provided screen shot of the system PATH.

 

Thank you again,

jcfox

systemPath.PNG
0 Kudos
anatoli
Moderator
Moderator
4,266 Views
Registered: ‎06-14-2010

Hello @jcfox

 

I can see your machine’s java is on the top of the list in the PATH, so when you are running .settings64-Vivado.bat (or settings64.bat), you are adding all of the Vivado related folders into the path, including Java location; however, seems like the system then still detects and uses your machine’s Java instead and that is what’s most likely causing this issue.

 

Can you please try the below steps and see if Vivado GUI still can’t be opened after following these steps?

 

  • Open a windows command prompt and set your PATH to something different as to what it is currently set, i.e. basically clear it (please note that you are not clearing it “globally” on this PC, but only clearing this within this command prompt) 

e.g.

set path=

 

(see my screenshot as an example) 

  • Check that the PATH is now not set to anything and you can do this by typing 'path' as the command and this should return PATH=<null>, as can be seen in my screenshot below
  • Then CD to the location such as \Xilinx\Vivado\2017.4
  • Run settings64.bat
  • Now PATH should be set to point to all of the Vivado 2017.x related directories (see my screenshot as an example)
  • Within the same command prompt, navigate to any directory with full read and right permissions and then from this location open Vivado by running this command: vivado
  • Then see if you are still seeing the same issue or not and if Vivado opens this time?
Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
Forum_1.JPG
jcfox
Visitor
Visitor
4,255 Views
Registered: ‎08-03-2017

Hello @anatoli,

 

Thank you for your clear instructions but unfortunately this did not correct the problem. I am attaching an image of what I ran and also the logs that were generated (not really much to see here besides the version numbers).

 

Thank you again for the support,

jcfox

vivadoPath.PNG
anatoli
Moderator
Moderator
6,147 Views
Registered: ‎06-14-2010

Hello @jcfox,

 

 

Apologies, I was out until today and couldn’t respond any sooner.

 

Are there any updates regarding this issue? Were you able to overcome this issue yet?

 

To me, the issue is something to do with the Fall Creator Update. I'm out of ideas why this is happening at your machine.

Would you have access to a different host running Win10 Fall Creators Update? If so, can you please check and see if the problem reproduces there?

 

As a suggestion, you can also try uninstalling Fall Creators Update by following these steps:

 

This is documented here: https://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install-winpc/how-to-use-the-rollback-function-in-windows-10/3e9e5c2d-239f-488c-9f48-64a226302657

 

With Windows 10, it seems Microsoft has listened and has provided a welcome option to its recovery tools to make it easy to uninstall Windows 10 latest update and go back to your previous version of Windows 10. 

 

To uninstall the Fall Creators Update, go to Start > Settings and click on Update & Security.

Click the Recovery link on the left and then click on Get started under 'Go back to the previous version of Windows 10.'

 

That way you should be able to revert back to Win 10 1703 (Creator Update). 2017.4 is supported on this OS (means that we (Xilinx) has tested 2017.4 on Creators update, where as with 2017.4 and Fall Creators Update, only some limited tests were performed), so you shouldn't see this issue then.

 

Can you give this a try and see if you'd get a better outcome?

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------

View solution in original post

4,174 Views
Registered: ‎01-22-2015

@anatoli

 

I’m having problems similar to those reported by @jcfox with Vivado v2017.3.   Here’s my experience – hope it helps you.

 

12Dec17: Installed Vivado v2017.3 under WIN10 – but had to use fix described by @bandi at <this post>

 

12Dec17-26Jan18:  Vivado v2017.3 working fine

 

29Jan18:   

    Installed WIN10 Fall Creators Update 1709 (build 16299) (~ 1hr)   

   

    Vivado v2017.3 fails to launch and gives following message:

          Error when launching "C:\Xilinx\Vivado\2017.3\bin\vivado.bat": Launcher time out

 

    Uninstalled WIN10 Update (~1hr) using “Settings > Update & Security > Recovery >Go Back to Previous Version of WINDOWS 10”   

 

    System Information now reports WIN10 build 15063   

 

    Paused WIN10 Updates: “Settings > Update & Security > Windows Update > Advanced Options > Pause Updates = ON”

  

    Vivado v2017.3 now launches successfully and runs properly !

 

 

A final note: In Dec2017, I also installed Vivado v2017.3 on a WIN7 machine without problems – and it has been running without problems since Dec2017.

anatoli
Moderator
Moderator
4,165 Views
Registered: ‎06-14-2010

Hello markg@prosensing.com,

 

Thanks a lot for sharing your workaround that works for you. This should definitely help others with the same problem in the future.

We are still investigating why this problem occurs with Fall Creator (1709) update, and hopefully will come up soon with a permanent solution. Anyhow, for now, we'd need to use this workaround.

 

Thanks once again and have a nice day.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos
jcfox
Visitor
Visitor
4,158 Views
Registered: ‎08-03-2017

Hello @anatoli and markg@prosensing.com,

 

I highly appreciate both of your responses and your clear instructions markg@prosensing.com. I just wanted to give a small update as to what is going on before I mark this problem is solved. Last week I had to hand off the machine to our IT department to have the system rolled back but have yet to receive it back to verify that this would solve the problem. I am pretty sure that once we roll back the system it will work once again but I wanted to wait until I get the machine back to verify the problem has been fixed before marking a solution.

 

Thank you both again for assistance!

jcfox

0 Kudos
anatoli
Moderator
Moderator
4,034 Views
Registered: ‎06-14-2010

Hello @jcfox,

 

Thanks for letting us know.

 

Just wanted to check with you to see if your issue got resolved after reverting back to the previous update of your windows 10 OS?

 

Thanks in advance and have a nice day.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos
jcfox
Visitor
Visitor
4,021 Views
Registered: ‎08-03-2017

Hello again @anatoli,

 

I wanted to say thank you again for all the amazing support you have provided us!

 

Sorry it took a while to get back to you but our IT department said it took them a while to get it all figured out because Microsoft removed the ability to roll back the machine to previous build from their website and through the local security restore. In the end we had to do a fresh install of Windows 10 to roll back to a previous version to get Vivado working again.

 

Again I just want to give out a small PSA to anyone who may find this again in the future to help you out:

 

As of the time of writing this Microsoft only gives out a 10 day grace period to roll back your machine through Settings > Security and once that period is over you can't uninstall the update through this method anymore. I would also be highly recommend blocking the fall creator's update once your system has been rolled back because Microsoft will try to obtain the newest release version and reinstall it on the system again.

 

Again thank you so much @anatoli!

jcfox

0 Kudos
anatoli
Moderator
Moderator
4,014 Views
Registered: ‎06-14-2010

Thanks for letting us know @jcfox and i'm glad to hear your issue eventually got sorted. Also, thanks a lot for the info about the Microsoft's 10 day grace period to roll back, I wasn't aware of this until now. 

 

FYI - 

Please note that since Microsoft will now release major Windows 10 updates every March and September, so every 6 months, this means that this is overlapping with the Vivado releases.

To avoid the above situation, and as each Microsoft Win10 update that comes out only supported for a year (or perhaps year and a half) after it releases, we are currently discussing on considering supporting and using Win10 Long-Term Servicing Branch (LTSB) instead (Long-Term Servicing Branch/Channel means it will be supported for 10 years from the date of release).

However, there are many factors here that needs to be taking into the consideration to make this decision of moving to the LTSB versions of Windows 10 as our official stance, so this is just as an indication or as an FYI to you and other Win 10 users, to show that Xilinx do care about our customers and we are continually working towards better solutions in such situations, to meat the requirements and to maintain customers' satisfaction high. 

 

Anyhow, thanks once again and have a nice day/evening.

  

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos
3,304 Views
Registered: ‎01-22-2015

@anatoli

 

Is the solution still to block the Fall (2017) creators update to WIN10?

 

The WIN10 "pause updates" that I did in Feb lasted for only 30days - and now my PC again has Fall creators update - and Vivado v2017.3 again does not launch - ugh.

 

Thanks,

Mark

0 Kudos
anatoli
Moderator
Moderator
3,279 Views
Registered: ‎06-14-2010

Hello markg@prosensing.com,

 

As this is in relation to 2017.3 and Win 1709 (Fall Creators Update), as this is unsupported OS for 2017.3, you can try workaround this issue by using the below steps. Can you please confirm that you've followed these steps and still seeing the same issue with Vivado 2017.3, where it is failing to launch/time out?

 

  1. Navigate to (Vivado Installed Directory)\2017.3\bin\unwrapped\win64.o
  2. Backup 'vivado.exe' by renaming it to 'vivado.exe.backup'
  3. Copy 'vivado-vg.exe' and paste it into the same folder . You will find it in the same folder (Vivado Installed Directory)\2017.3\bin\unwrapped\win64.o). 
  4. Rename 'vivado-vg - Copy.exe' to 'vivado.exe' . Then launch vivado.

If the above WA doesn't solve your issue, then you can try uninstalling Fall Creators Update by following these steps:

 

This is documented here: https://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install-winpc/how-to-use-the-rollback-function-in-windows-10/3e9e5c2d-239f-488c-9f48-64a226302657

 

With Windows 10, it seems Microsoft has listened and has provided a welcome option to its recovery tools to make it easy to uninstall Windows 10 latest update and go back to your previous version of Windows 10. 

However, I believe this option is only available for 30-days after a new update was applied.

 

To uninstall the Fall Creators Update, go to Start > Settings and click on Update & Security.

Click the Recovery link on the left and then click on Get started under 'Go back to the previous version of Windows 10'.

Forum_15.png

 

Can you give this a try and let me know if after reverting back to Win10 Creators Update, you are still seeing the same problem or not?

 

Hope this helps? 

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
3,273 Views
Registered: ‎01-22-2015

@anatoli

 

The workaround (renaming vivado-vg.exe) that you suggested worked for me !

 

I've installed v2017.3 on two machines, both running WIN10 with 1709 update.  One machine has given me no problems with Vivado updates, the other machine frequently gives problems.  Wierd!

 

I'm sure these problems must be very frustrating for you to deal with. 

 

Thanks for your clear and patient reply.

 

Mark

0 Kudos
3,251 Views
Registered: ‎01-22-2015

@anatoli

 

Thought it might be helpful to know that I have Vivado v2017.3 installed on two WIN10 machines:

 

1) Microsoft Windows 10 Pro,     Version 10.0.16299 Build 16299, Xeon(R) CPU W3503 @ 2.40GHz, 8GB RAM

2) Microsoft Windows 10 Home, Version 10.0.16299 Build 16299, i5-7400 CPU @ 3.0GHz, 12GB RAM

 

On WIN10-Pro machine, I've had almost every one of the Vivado problems mentioned in the Forum.

On WIN10-Home machine, I've had NO problems!

 

Mark

0 Kudos
anatoli
Moderator
Moderator
3,244 Views
Registered: ‎06-14-2010

Thanks markg@prosensing.com for letting us know. This is definitely a useful information, as this would explain why some users seeing issues with Vivado 2017.x on Win 10 OS and others - having no problem at all.

I've passed this on to out software development team and will update you later with a feedback received from them.

 

Have a lovely day.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos