cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Observer
Observer
4,926 Views
Registered: ‎03-31-2009

webpack and planahead

Jump to solution

Do I need t have already purchased PlanAhead to use it with a Webpack license?  I need to install ISE/PlanAhead 14.1 or newer for some maintenance on an existing Spartan6 design. 

 

I set up a webpack license but I don't see anything about PlanAhead: 

 

# ----- REMOVE LINES ABOVE HERE --------------------------
#
# This license is valid from Fri Nov 04 00:55:14 UTC 2016.
#
# This is license NODELOCKED to HOSTID=ANY;
# there is no need to run lmgrd for this license.
#
#
# This is a permanent license generated on Fri Nov 04 00:55:14 UTC 2016
INCREMENT SDK xilinxd 2017.11 permanent uncounted 3xxxx1F3BEB4 \
VENDOR_STRING=xxx,SDK,software,permanent,_210566005_0_0_405 \
HOSTID=ANY ISSUER="Xilinx Inc" START=04-Nov-2016 TS_OK
#
# This is a permanent license generated on Fri Nov 04 00:55:14 UTC 2016
INCREMENT Analyzer xilinxd 2017.11 permanent uncounted Dxxxx48712CB \
VENDOR_STRING=xxx,Analyzer,software,permanent,_210566005_0_0_843 \
HOSTID=ANY ISSUER="Xilinx Inc" START=04-Nov-2016 TS_OK
#
# This is a permanent license generated on Fri Nov 04 00:55:14 UTC 2016
INCREMENT HLS xilinxd 2017.11 permanent uncounted 5xxxxF00C68B \
VENDOR_STRING=xxx,HLS,software,permanent,_210566005_0_0_521 \
HOSTID=ANY ISSUER="Xilinx Inc" START=04-Nov-2016 TS_OK
#
# This is a permanent license generated on Fri Nov 04 00:55:14 UTC 2016
INCREMENT V_WebPACK xilinxd 2017.11 permanent uncounted CxxxxA9813F3 \
VENDOR_STRING=xxx,V_WebPACK,software,permanent,_210566005_0_0_326 \
HOSTID=ANY ISSUER="Xilinx Inc" START=04-Nov-2016 TS_OK
#
# ----- REMOVE LINES BELOW HERE --------------------------

 

I've seen other posts where people had the same issue but the answer was never documented.  A contractor with PlanAhead did this design originally.  Can I modify it with Webpack? 

 

0 Kudos
Reply
1 Solution

Accepted Solutions
Observer
Observer
8,857 Views
Registered: ‎03-31-2009

That is correct.  For some reason I could not access the ISE Webpack license via the license site so my FAE had to send me a license.  The proper license looks something like this: 

 

# This is a permanent license generated on Tue Nov 08 18:00:56 UTC 2016
INCREMENT ISE_WebPACK xilinxd 2017.11 permanent uncounted \
92xxxx1xxxx8 \
VENDOR_STRING=xxx,ISE_WebPACK,software,permanent,_151388_202xxx033_0_116 \
HOSTID=ANY ISSUER="Xilinx Inc" START=08-Nov-2016 TS_OK
#
#
# ----------------------------------------------------------------------
#  The following PACKAGE definition is a REQUIRED part of this license:
#
PACKAGE ISE_WebPACK xilinxd 2017.11 xxxx2Fxxxx54 COMPONENTS="SDK \
ChipScopePro_SIOTK ChipscopePro WebPACK XC7Z010 XC7Z030 HLS \
xps_tdp XC7Z020 PlanAhead" OPTIONS=SUITE
#

 

No, you cannot use this license because the codes have been modified. You need to download the ISE_Webpack license or request a license from your FAE. 

View solution in original post

0 Kudos
Reply
7 Replies
Xilinx Employee
Xilinx Employee
4,920 Views
Registered: ‎04-16-2012

Hi @johndap

 

Which device are you targeting?

If you are targeting WebPACK device, then you need an ISE WebPACK (free) license.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Reply
Xilinx Employee
Xilinx Employee
4,903 Views
Registered: ‎08-01-2008
Check the license status. This license doesn't have plan ahead. You may need to contact your FAEs
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Reply
Observer
Observer
4,889 Views
Registered: ‎03-31-2009

@vuppala XC6SLX16-2CSG225 so the software_matrix.pdf says WebPack should support it.

0 Kudos
Reply
Observer
Observer
4,886 Views
Registered: ‎03-31-2009

@balkris - does your license specifically list PlanAhead? 

0 Kudos
Reply
Moderator
Moderator
4,882 Views
Registered: ‎01-16-2013

@johndap,


Can you please share the xinfo report?

 

To generate xinfo file,

start menu start->Xilinx ISE design suite->Accessories->xinfo system checker. 

It will generate xinfo.txt file. Please attach it here

 

Make sure you are pointing the Licenseing correctly.

Open the XLCM (start --> ISE Design Suite --> Accesories --> Manage Xilinx Licenses). Now enther the path to license file in XILINXD_LICENSE_FILE box (say C:/Xilinx_license/xilinx.ic) and click on set.

 

Regards,
Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Reply
Xilinx Employee
Xilinx Employee
4,862 Views
Registered: ‎04-16-2012

Hi @johndap

 

The license you pasted in your first post doesnt have ISE WebPACK license.

Since you are targeting WebPACK device, you have to generate ISE WebPACK license. 

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Reply
Observer
Observer
8,858 Views
Registered: ‎03-31-2009

That is correct.  For some reason I could not access the ISE Webpack license via the license site so my FAE had to send me a license.  The proper license looks something like this: 

 

# This is a permanent license generated on Tue Nov 08 18:00:56 UTC 2016
INCREMENT ISE_WebPACK xilinxd 2017.11 permanent uncounted \
92xxxx1xxxx8 \
VENDOR_STRING=xxx,ISE_WebPACK,software,permanent,_151388_202xxx033_0_116 \
HOSTID=ANY ISSUER="Xilinx Inc" START=08-Nov-2016 TS_OK
#
#
# ----------------------------------------------------------------------
#  The following PACKAGE definition is a REQUIRED part of this license:
#
PACKAGE ISE_WebPACK xilinxd 2017.11 xxxx2Fxxxx54 COMPONENTS="SDK \
ChipScopePro_SIOTK ChipscopePro WebPACK XC7Z010 XC7Z030 HLS \
xps_tdp XC7Z020 PlanAhead" OPTIONS=SUITE
#

 

No, you cannot use this license because the codes have been modified. You need to download the ISE_Webpack license or request a license from your FAE. 

View solution in original post

0 Kudos
Reply