UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
156 Views
Registered: ‎07-24-2018

Xilinx AI SDK v2.0.5 issue with UG1354 Setting up ZCU104

Jump to solution

I am trying to run the included demos from the AI SDK from the AI developer hub (https://www.xilinx.com/products/design-tools/ai-inference/ai-developer-hub.html#edge) using the instructions starting in Chapter 2 (page 12) of the UG1354 document.  I am able to successfully set up my host machine without any errors, however when I go to the "Setting up the Target" section (page 16) I fail. 

Question 1:

I have downloaded the board image (xilinx-zcu104-prod-dpu1.4-desktop-buster-2019-04-23.img.zip) from the AI developer hub - is this the right image to use for the AI SDK and the ZCU104?  I used it since it was referenced in this post as working: https://forums.xilinx.com/t5/Machine-Learning/Customize-DPU-IP-and-run-Xilinx-AI-SDK-examples-on-Xilinx/td-p/979083

Question 2: 

In step 2, installing the AI Model Package I am successful in scp the xilinx_ai_model_ZCU104_2019.1-r1.deb file to the / directory of my board.  However, when I run the "dpkg -i xilinx_ai_model_ZCU102_2019.1-r1.deb" command I get an error:

Error: System required version 4.19.0-xilinx-v2019.1

 

My best guess is that the issue stems from using the incorrect board image but I'm not sure which is the correct.  Any help would be greatly appreciated!

 

0 Kudos
1 Solution

Accepted Solutions
Contributor
Contributor
138 Views
Registered: ‎07-24-2018

Re: Xilinx AI SDK v2.0.5 issue with UG1354 Setting up ZCU104

Jump to solution

So, the answer to both question 1 and 2 is to use a different board file other than the one I mentioned in the linked related forum post. 

After using the image file: petalinux-user-image-zcu104-zynqmp-sd-20190802.img.gz I was able to finish the installation of the AI SDK onto my ZCU104.

View solution in original post

0 Kudos
1 Reply
Contributor
Contributor
139 Views
Registered: ‎07-24-2018

Re: Xilinx AI SDK v2.0.5 issue with UG1354 Setting up ZCU104

Jump to solution

So, the answer to both question 1 and 2 is to use a different board file other than the one I mentioned in the linked related forum post. 

After using the image file: petalinux-user-image-zcu104-zynqmp-sd-20190802.img.gz I was able to finish the installation of the AI SDK onto my ZCU104.

View solution in original post

0 Kudos