cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
243 Views
Registered: ‎09-10-2020

Ethernet throughput test on Zynq

Jump to solution

Hello,

We are using a custom board of the ZYNQ 7045 FFG package and trying to do an Ethernet throughput test based on xapp1026. We followed all the configuration settings required in ZYNQ and also in PC as mentioned in xapp1026. But our applications in ARM are getting hanged either in pre-fetch abort or data abort and the iperf application in PC is not receiving any further data. But when we try the same on the Xilinx ZC706 evaluation board it is working fine and getting the expected speeds without any interruption. Source files and settings used on both (custom and Xilinx) hardware are the same.

One observation is this problem is coming only when we are trying to do data transfer at a higher data rate. For normal speeds, it is working fine.

The Ethernet IC chipset used in our custom board is Marvell 88E1512. The DDR IC chipset used in our custom board is MT41K256M 16HA-125. 

Can we debug anything by observing the XML file (the one in system_hw_platform folder) that is generated when creating the project in the ISE tool? Please throw some light on this issue which will help us in debugging. 

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
183 Views
Registered: ‎11-09-2017

Hi @msriharirao 

Seems that issue happening at higher frequencies, i suspect over memory interface.

SDK provides PS DRAM diagnostic test (only memory test without Ethernet functionality). Run this test at higher frequency at check the behavior.

If standalone memory test hangs at higher frequency then you should start debugging on it.

Regards
Pratap

Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful.

View solution in original post

1 Reply
Highlighted
Moderator
Moderator
184 Views
Registered: ‎11-09-2017

Hi @msriharirao 

Seems that issue happening at higher frequencies, i suspect over memory interface.

SDK provides PS DRAM diagnostic test (only memory test without Ethernet functionality). Run this test at higher frequency at check the behavior.

If standalone memory test hangs at higher frequency then you should start debugging on it.

Regards
Pratap

Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful.

View solution in original post