cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Anonymous
Not applicable
10,446 Views

MIG missing input clock option

Jump to solution

Hello, i am having a problem with the Memory Interface Generator v2.4 in Vivado 2015.3. I am following the example design from Xilinx, more precisely XTP206 - VC707 MIG Tutorial.

When i run the MIG, under memory options there should be a selection box for the input clock period, this is missing. In page 20 of the previously mentioned pdf, this particular box is showed, there i must set the period to 5000 ps for my board.

In order to solve the problem i downloaded the newest version of Vivado, 2016.1, again i encounter the same problem. I am running Vivado on Ubuntu 14.04 LTS.

 

Does anyone know a solution or a workaround to this problem?

 

Thank you in advance.

0 Kudos
1 Solution

Accepted Solutions
vsrunga
Xilinx Employee
Xilinx Employee
18,230 Views
Registered: ‎07-11-2011

@Anonymous

 

Looks typical.

Is it possible to check this in a different machine with any supported operating systems?

Also try changing the FPGA part and memory settings and see how it goes.

 

-Vanitha

 

---------------------------------------------------------------------------------------------
Please do google search before posting, you may find relavant information.
Mark the post - "Accept as solution" and give kudos if information provided is helpful and reply oriented

View solution in original post

11 Replies
criley
Xilinx Employee
Xilinx Employee
10,425 Views
Registered: ‎08-16-2007

What clock period do you have set before going to the Memory Options page in the IP GUI?

Can you attach a screen shot of the Memory Options page in the IP GUI showing the "Input Clock Period" missing?

I doubt this is related to the version of Ubuntu you are using but UG973 says that only Ubuntu Linux 14.04.3 LTS is supported. Can you try using this version of Ubuntu?

0 Kudos
Anonymous
Not applicable
10,416 Views

I left the default value 1250 ps for 800 MHz.

 

Screenshot from 2016-05-31 20:10:59.png
0 Kudos
vsrunga
Xilinx Employee
Xilinx Employee
18,231 Views
Registered: ‎07-11-2011

@Anonymous

 

Looks typical.

Is it possible to check this in a different machine with any supported operating systems?

Also try changing the FPGA part and memory settings and see how it goes.

 

-Vanitha

 

---------------------------------------------------------------------------------------------
Please do google search before posting, you may find relavant information.
Mark the post - "Accept as solution" and give kudos if information provided is helpful and reply oriented

View solution in original post

Anonymous
Not applicable
10,340 Views
I tested it in another pc running Arch Linux and everything was ok.
0 Kudos
gotfrydkonrad
Visitor
Visitor
8,571 Views
Registered: ‎07-23-2016

I apologize about posting in this topic which is marked as solved, but I have the same problem, and posted solution unfortunately does not work for me. I will appreciate every reply and solutions. 

Part which I am using: xc7k325tffg900-2
Vivado versions and operating systems on which problem have occured:
Scientific Linux 7.2 and Vivado 2016.1
Scientific Linux 7.2 and Vivado 2016.2
Arch Linux and Vivado 2016.1
Arch Linux and Vivado 2016.2
Ubuntu 14.04.4 LTS and Vivado 2016.2

I have been searching for related issues, but I could not find anything better than this topic.
If answer is easy to find, I will be very sorry of noise, which I have made.


0 Kudos
olwefin
Observer
Observer
7,652 Views
Registered: ‎12-22-2014

Hello,

 

Facing the same problem, I've found this post.

we're using Vivado 2016.2 and Cent OS 7.1.

We're tried on several machine and the problem remains...

 

Any suggested work around ?

 

thanks and regards

0 Kudos
gotfrydkonrad
Visitor
Visitor
7,604 Views
Registered: ‎07-23-2016

I have used Windows 8.1.

I have archived project on my remote computer (Scientific Linux), then booted to win8 on local PC, set MIG, again archived project, deleted original project directory (make backup first), extracted archive on remote PC and have never opened MIG configuration on Scientific Linux again.

(my local PC is to weak for synthesis/implementation).

0 Kudos
Anonymous
Not applicable
7,314 Views

hello, 

just to report same issue as described on the snapshot above.

on ubuntu 14.04 + 2015.1/2016.2/2016.2

 

hope someone will find an other solution rather than changing OS...

0 Kudos
olwefin
Observer
Observer
5,878 Views
Registered: ‎12-22-2014

Hello all,

 

after a long discussion with Xilinx India Design team, the root cause came from the fact that my environment is set to French Language. making a confusion with decimal number where the fraction part would be separated with ,  instead of a .  in english language.....

 

Changing the OS language to english, or launching Vivado with an english locale environment option, made the MIG working as expected.

 

I've been told that an AR would be written but I've never heard yet the AR#  ID.

 

But At least there is a workaround that works fine.

 

regards,

 

Olwefin

Tags (1)
martoni
Observer
Observer
3,638 Views
Registered: ‎02-20-2009

2017.1 doesn't fix this bug.

 

Just for information, with debian jessie the problem is the same on vivado 2017.1 :

 

mig_clock_bug.png

 

I will try the english language workarround.

0 Kudos
martoni
Observer
Observer
3,632 Views
Registered: ‎02-20-2009

Ok I "solved" the problem on debian jessie with the workaround described by Olwefin.

 

To solve it we have to change numeric language used by vivado (the comma problem). It can be done by enter this command before launching vivado :

 

$ export LC_NUMERIC=en_US.utf8

 

Then launch vivado in the same console :

 

$ vivado

The export can be added in settings64.sh to automatize it.

 

mig_clock_nobug.png