UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor gs_medinok
Visitor
100 Views
Registered: ‎04-14-2016

Missing Interfaces in xparameters.h

In Vivado 2018.3  block design, I added 10G/25G Ethernet Subsystem (2.5) and I configured 'Num of Cores' = 2, results with two slave interfaces.

The project device is ZCU102 Evaluation Board.

The Address Editor shows two Offset_Address (0x00_A000_3000, 0x00_A000_4000); the same are also in 'system.hdf'.

Exported the hardware to SDK and created the project and BSP, in the file 'xparameters.h', I found only one base address:

XPAR_XXV_ETHERNET_0_BASEADDR = 0x00_A000_4000

but missing the base address: 0x00_A000_3000

Is there a problem?  (Could be two 'Cell' with the same name in the system.hdf)1

Thanks

0 Kudos
1 Reply
Visitor gs_medinok
Visitor
35 Views
Registered: ‎04-14-2016

Re: Missing Interfaces in xparameters.h

to better detail my previous message, I attached block diagram and an excerpt from  xparameters.h: there is only the base addr 0xA0004000 but is missing the address 0xA0003000

/* Definitions for driver XXVETHERNET */
#define XPAR_XXXVETHERNET_NUM_INSTANCES 1
/* Definitions for peripheral XXV_ETHERNET_0 */
#define XPAR_XXV_ETHERNET_0_DEVICE_ID 0
#define XPAR_XXV_ETHERNET_0_BASEADDR 0xA0004000
#define XPAR_XXV_ETHERNET_0_HIGHADDR 0xA0004FFF
#define XPAR_XXV_ETHERNET_0_STATS 0
#define XPAR_XXV_ETHERNET_0_PHYADDR 0

/* Canonical definitions for peripheral XXV_ETHERNET_0 */
#define XPAR_XXVETHERNET_0_DEVICE_ID 0
#define XPAR_XXVETHERNET_0_BASEADDR 0xA0004000
#define XPAR_XXVETHERNET_0_HIGHADDR 0xA0004FFF
#define XPAR_XXVETHERNET_0_STATS 0
#define XPAR_XXVETHERNET_0_PHYADDR 0
#define XPAR_XXVETHERNET_0_INTR 0xFF

0 Kudos