UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer creator
Observer
1,581 Views
Registered: ‎12-07-2018

why my zedboard not executing lwip echo server

Jump to solution

when I my device(zedboard)  from my computer it shows that destination host unreachable???? please tell me the solution....

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
1,561 Views
Registered: ‎04-01-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Hi @creator

Are you monitoring the Lwip Echo server messages in the Serial Port (terminal), if so whether it got negotiated for the speed. Please attach the screen shot of the UART messages to this thread to check with.

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
20 Replies
Moderator
Moderator
1,562 Views
Registered: ‎04-01-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Hi @creator

Are you monitoring the Lwip Echo server messages in the Serial Port (terminal), if so whether it got negotiated for the speed. Please attach the screen shot of the UART messages to this thread to check with.

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Observer creator
Observer
1,476 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Hello.Thank you  for your response. 

I dumped LWIP echo server program on zedboard.When I ping the zedboard from my computer it show like mentioned in screenshot.

My computer IP:192.168.1.12

My zedboard IP :192.168.1.10  

what is port 7???

doubt.PNG
0 Kudos
Observer creator
Observer
1,450 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

please reply sir..

0 Kudos
Moderator
Moderator
1,444 Views
Registered: ‎04-01-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

HI @creator

Can you please share with me the UART debug print screen shot to check with. It also depends on the settings you have done at PC. I believe you have set a static IP at the PC. Can you also check for the negotiated speed at the PC and even in the UART debug statements of Zed board (please share the screen).

As per your question on what is Port, as you are running a Server at Zed board it will have a port address  when you want to connect it with a client. we can discuss on this further once you get the Ping working. 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Observer creator
Observer
1,437 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

what is UART debug print screen??

0 Kudos
Highlighted
Observer creator
Observer
1,429 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Hello sir.Actually fisrt I connected the block diagram using zynq block,AXI interconnet,AXI GPIO blocks.

Then I generate the bitstream and export it to hardware,Lanuch SDK

Then I create LWIP echo server project,

I connect the zedboard to my pc and I connnect  my pc LAN to My zedboard ethernet port.

When I power on zedboard the LED at ethernet port start blinking in yellow color.

I program the FPGA then blue light is blinked on zedboard.

From Internet I knew that first we have to check whether our pc connect with zedboard or not ?

So I ping the zedboard with assigned IP but my pc shows destination host unreachable.

In my pc adapter seetings  

Ip:192.168.1.12

subnet mask:255.255.255.0

gateway:192.168.1.0

DNS server:10.1.3.5

alternate DNS server:10.1.3.6

0 Kudos
Moderator
Moderator
1,418 Views
Registered: ‎04-01-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Hi @creator

Can you try with gateway changing to 192.168.1.1 and clearing the DSN server fields. 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
Observer creator
Observer
1,408 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Thank you for your reply sir.I did the same what you told .

I successfully executed the lwip echo server. when I ping my computer It replies how many packets send and receive.

Now I want to transfer some data to zedboard like a file or video etc. and I want to see the reply from zedboard.

please tell me how to see the output and tell which software to use output data.

0 Kudos
Moderator
Moderator
1,404 Views
Registered: ‎04-01-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Hi @creator

Please try to follow XAPP1026 for the File Transfers (TFTP). 

https://www.xilinx.com/support/documentation/application_notes/xapp1026.pdf

It has below applications

zedboard_1026.PNG

you can go through the reference design downloaded. 

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
Observer creator
Observer
1,398 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Thankyou 

0 Kudos
Observer creator
Observer
1,377 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Hello.

If I want to send data to zed board shall I need to boot the zedboard with linux os or any other os.

please clarify my doubt..

 

 

0 Kudos
Visitor belqassim_84
Visitor
1,364 Views
Registered: ‎10-04-2018

Re: why my zedboard not executing lwip echo server

Jump to solution
did you Check the MAC@ (should be the same as your board's) used in your program?
0 Kudos
Visitor belqassim_84
Visitor
1,362 Views
Registered: ‎10-04-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

MAC or physical @ 

0 Kudos
Moderator
Moderator
1,354 Views
Registered: ‎04-01-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Hi @creator

That may be your choice to use baremetal application from XAPP1026 or you can boot linux if you are comfortable doing so.

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Observer creator
Observer
1,346 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

can't we do it by using windows 10???

0 Kudos
Observer creator
Observer
1,340 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

we are getting an error while generating bitstraem of ethernet fmc by using echo server,can u suggest me how to overcome it?we are attaching screenshot of error????

ether.PNG
0 Kudos
Moderator
Moderator
1,333 Views
Registered: ‎04-01-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Hi @creator

Can you please create a new thread in Networking and Connectivity Board for the hardware connectivity and if you are facing issues with the linux porting on zedboard you can create a post in the  Embedded Linux Board. Thanks for your understanding on this. 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Observer creator
Observer
1,329 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Sir please tell me that why we need os on zedboard .can we do with out os???

0 Kudos
Moderator
Moderator
1,314 Views
Registered: ‎04-01-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Hi @creator

You can do the File transfer using TFTP application as provide in XAPP1026 with out linux. I am suggesting for the post can be further discussed if you need any hardware related issues (FMC attached PHY) in a right board i.e., Networking and Interface  so that other may get visibility of the post.

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Observer creator
Observer
1,303 Views
Registered: ‎12-07-2018

Re: why my zedboard not executing lwip echo server

Jump to solution

Ok.Thankyou for your explanation.

Now my new doubt is how to do file transfer with TFTP protocol??

Can you please give any Idea how to proceed?

 

0 Kudos