cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
541 Views
Registered: ‎11-02-2019

OpenAMP with ubuntu echo_test not found

Jump to solution

Hi!

I am trying to boot openamp with ubuntu on a ZCU102. I have followed the steps here: https://forums.xilinx.com/t5/OpenAMP/Openamp-with-Ubuntu-ZCU102/td-p/814504

I have done this:

1. Create a petalinux project with the zcu102 bsp

2. In petalinux-config select SD card as rootfs type

3. In petalinux-config -c rootfs include openamp package

4. Include openamp.dtsi in the device tree

5. In petalinux-config -c kernel change to "yes" in Remoteproc drivers

6. Create a SDK application for the R5_0 using the template of OpenAMP echo_test

7. Create and enable an app in the petalinux project, copy the .elf of the application there and change the .bb to include it in /lib/firmware

8. Build the project and package the image

9. Burn the .img of the ubuntu provided here (https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841937/Zynq+UltraScale+MPSoC+Ubuntu+part+2+-+Building+and+Running+the+Ubuntu+Desktop+From+Sources) in the SD card

10. Replace all the contents of the BOOT partition with the BOOT.bin, image.ub and system.dtb of our petalinux project

11. Replace the contents of /lib/modules in the ROOT partition with the ones in cpio.rootfs of our project

12. Copy the .elf of the SDK application in /lib/firmware (I don't know if this is necessary)

Then, I can boot  and create the remoteproc successfully with the comands "echo stan.elf> /sys/class/remoteproc/remoteproc0/firmware" and "echo start > /sys/class/remoteproc/remoteproc0/state". But when I do "echo_test" I get an error message that says that the command echo_test is not found.

Does anybody have an idea of what I am doing wrong or what can I be missing?

0 Kudos
1 Solution

Accepted Solutions
315 Views
Registered: ‎11-02-2019

I solved my problem copying the echo_test file from <project>/images/linux/rootfs.cpio/usr/bin to the /usr/bin directory in the rootfs of ubuntu (in the ROOT partition of the SD).

View solution in original post

0 Kudos
3 Replies
jovitac
Moderator
Moderator
499 Views
Registered: ‎05-10-2017

Did you enable the open-amp applications in the rootfs? 

Filesystem Packages --->
-> Petalinux Package Groups
-> packagegroup-petalinux-openamp

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
449 Views
Registered: ‎11-02-2019

Hi @jovitac 

Yes, I did that.

0 Kudos
316 Views
Registered: ‎11-02-2019

I solved my problem copying the echo_test file from <project>/images/linux/rootfs.cpio/usr/bin to the /usr/bin directory in the rootfs of ubuntu (in the ROOT partition of the SD).

View solution in original post

0 Kudos