UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor claudiofi
Visitor
9,448 Views
Registered: ‎02-25-2016

Petalinux 2015.2.1 BSP and OpenAMP Framework

Hello to all,

I'm trying to test the AMP configuration (Linux+FreeRTOS) on my MicroZED board and I'm following  the userguide UG1186.
Unfortunatelly in my Petalinux config I'can't see any modules to enable. The Modules options is empty, when I should check that the following modules are enabled.

Modules --->
     [*] rpmsg_proxy_dev_driver --->
     [*] rpmsg_user_dev_driver --->

Do you have some idea about what is the problem?

I'm using Vivado 2015.4 + Petalinux 2015.2.1 + PetaLinux 2015.2.1  BSP ( for z7010).

Thank you in advance,
Claudio

0 Kudos
5 Replies
Visitor claudiofi
Visitor
9,435 Views
Registered: ‎02-25-2016

Re: Petalinux 2015.2.1 BSP and OpenAMP Framework

Sorry...

 

I'm using Vivado 2015.4 + Petalinux 2015.4 + PetaLinux 2015.2.1  BSP ( for z7010).

0 Kudos
Xilinx Employee
Xilinx Employee
9,431 Views
Registered: ‎09-10-2008

Re: Petalinux 2015.2.1 BSP and OpenAMP Framework

Hi,

 

Have your tried the BSP that does with 2015.4 as that document UG1186 is new and applies to 2015.4 it seems like?

 

I see those modules in the components dir of my zc702 BSP.

 

Thanks

John

0 Kudos
Visitor claudiofi
Visitor
9,428 Views
Registered: ‎02-25-2016

Re: Petalinux 2015.2.1 BSP and OpenAMP Framework

Thank you so much for your answer... I'm using the BSP 2015.2 because in the avnet website there is this like last bsp for MicroZED board. Now I  try to build a new  petalinux project with the XILINX BSP 2015.4 for ZEDboard and I hope that this work.

 

Thank you so much,

 

Claudio

0 Kudos
Visitor claudiofi
Visitor
9,379 Views
Registered: ‎02-25-2016

Re: Petalinux 2015.2.1 BSP and OpenAMP Framework

Does someone know if there is a Petalinux  bsp package 2015.4 version for Avnet MicroZed board, too?

 

Thank you in advance,

 

Claudio

0 Kudos
Participant wdavidlee
Participant
7,521 Views
Registered: ‎02-21-2015

Re: Petalinux 2015.2.1 BSP and OpenAMP Framework

I too am looking for a Petalinux 2015.4 BSP for Microzed.

 

David

0 Kudos