cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
876 Views
Registered: ‎03-02-2017

Zynq 7000 - XC7Z030 MIO State at startup

Jump to solution

Hi, 

 

I wanted to know more about the state of the PS MIO at startup. I saw several answer on other topics but nothing that is really clear about this. 

 

The TRM state at table 6-18 that at boot the IO from 9 to 53 are in tri-state input with a pull-up, but it isn't stated elsewhere. Can someone point me to another clue about this behaviour ? 

 

We are physically seeing that the MIO signals are high when the zynq is unconfigured (blank) which is the same as when it boots up. 

 

Thank for the information 

 

Regards, 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
869 Views
Registered: ‎04-18-2011

If you look at the register map in the TRM appendix you can see the reset state of the MIO pin. 

It indeed resets a state where the output is High-Z and the pull up is enabled. 

 

Keith 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
1 Reply
Highlighted
Moderator
Moderator
870 Views
Registered: ‎04-18-2011

If you look at the register map in the TRM appendix you can see the reset state of the MIO pin. 

It indeed resets a state where the output is High-Z and the pull up is enabled. 

 

Keith 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos