UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor nghaitai248
Visitor
691 Views
Registered: ‎10-28-2017

Artix-7 FPGA AC701 : Running the BIST Application Erros

Jump to solution

I have purchased a Artix-7 FPGA AC701. I have installed Vivado, Tera Term, drivers and completed all the tutorials as described in the Artix-7 FPGA AC701 Evaluation Kit (Vivado Design Suite 2015.1). This document was included in our Evaluation Kit.

Documentation: 

https://www.xilinx.com/support/documentation/boards_and_kits/ac701/2013_2/ug967-ac701-eval-kit-getting-started.pdf

 

A few weeks later, we are trying to run the BIST application and we would like to test the features. Referring to pages 12 in chapter “basic hardware bring-up with built in self-test”, we are having difficulty replicating this experiment that we completed a few weeks ago. We are generating error:

 

ERROR: [Labtools 27-2149] File

C:/ac701_bist/ready_for_download/bist_app.bit File not found. Check file name and file permissions.

 

when we try to execute step 6: reference AC701 Getting Started Guide 

“In Vivado Design Suite, open a TCL shell and type:

source C:/ac701_bist/ready_for_download?bist_download.tcl”

 

Prior to running this command in the TCL command prompt, I have the device on and connecting to it using Tera Term. I am opening all applications and terminal programs while running the program as administrator. 

 

A few trouble shooting methods we have completed include the following:

 

-When we open device manager, select the device in USB ports, and check the drivers, device manager returns a message that all drivers are up to date. Device manager also indicates that the device is working properly. (We installed Vivado and completed this tutorial mid October 2017, so all installs was relatively recent).

-I moved the unzipped AC701 BIST Design files (RDF0220) to another directory, and reattempted this step. It still fails. 

-I used GIT Bash to check that all my files were in the correct directory, however errors are still being generated. 

-I have already did some research on these compile errors, and referred to solutions online, however after doing the suggested solutions, our issue is still not resolved. 

https://forums.xilinx.com/t5/Vivado-TCL-Community/Bitstream-File-Not-Found-permissions/td-p/560466

 

Thank you for your time,

Haitai Ng

0 Kudos
1 Solution

Accepted Solutions
Scholar austin
Scholar
974 Views
Registered: ‎02-27-2008

Re: Artix-7 FPGA AC701 : Running the BIST Application Erros

Jump to solution

Please,

 

One post is sufficient.

 

Are you pointing to the correct directory?  If it cannot find a file, something got moved.

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
1 Reply
Scholar austin
Scholar
975 Views
Registered: ‎02-27-2008

Re: Artix-7 FPGA AC701 : Running the BIST Application Erros

Jump to solution

Please,

 

One post is sufficient.

 

Are you pointing to the correct directory?  If it cannot find a file, something got moved.

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos