UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer bamb00dark
Observer
8,389 Views
Registered: ‎07-23-2012

PC can't recognize the PCIE

Jump to solution

Hi everyone,

 

I'm doing the tutorial following the documentation "Getting Started with the Xilinx Virtex-6 FPGA ML605 Evaluation Kit". In the section of "Getting Started with PCI Express PIO Demonstration", I encountered one recognition problem.

 

I'm using PciTree (version 2.04c) to do some test with the ML605 (Virtex-6 FPGA XC6VLX240T device), but after scan the PCIbus, the Xilinx PCI can't be found.

 

Does anyone have any idea with this problem.

 

Thanks in advance,

Fan

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Voyager
Voyager
12,741 Views
Registered: ‎04-02-2011

Re: PC can't recognize the PCIE

Jump to solution

Hi everyone,

 

I'm doing the tutorial following the documentation "Getting Started with the Xilinx Virtex-6 FPGA ML605 Evaluation Kit". In the section of "Getting Started with PCI Express PIO Demonstration", I encountered one recognition problem.

 

I'm using PciTree (version 2.04c) to do some test with the ML605 (Virtex-6 FPGA XC6VLX240T device), but after scan the PCIbus, the Xilinx PCI can't be found.

 

Does anyone have any idea with this problem.

 

Thanks in advance,

Fan


I suspect if there is a single reason to identify why it si not getting detected ?

 

if you had inserted the board in the slot following the guide lines mentioned in user guide and the relevant documents.

 

Can you check by rebooting the system after you program the device with .bit file.

If you still face the problem let us know.

 

Which version of Core your are using ?

 

I hope you had properly followed xtp044/45 for gnerating the core

View solution in original post

0 Kudos
4 Replies
Moderator
Moderator
8,385 Views
Registered: ‎08-25-2009

Re: PC can't recognize the PCIE

Jump to solution
Hi Fan,

Which operating system are you using? Is it WInXP? Did you try to restart the PC and see if PCIe can be recognized?

Thanks
"Don't forget to reply, kudo and accept as solution."
0 Kudos
Moderator
Moderator
8,370 Views
Registered: ‎06-29-2011

Re: PC can't recognize the PCIE

Jump to solution

It has been seen that Active State Power Management (ASPM) when enabled can cause issues with VIrtex-6 devices. Can you check to see if this is enabled and disable it and see if that helps.

 

The following AR#:36325 details how to disable the ASPM.

 

AR#:36325 - Design Assistant for PCI Express - How to Disable ASPM?

http://www.xilinx.com/support/answers/36325.htm

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

Kind regards,
Gareth
0 Kudos
Highlighted
Voyager
Voyager
12,742 Views
Registered: ‎04-02-2011

Re: PC can't recognize the PCIE

Jump to solution

Hi everyone,

 

I'm doing the tutorial following the documentation "Getting Started with the Xilinx Virtex-6 FPGA ML605 Evaluation Kit". In the section of "Getting Started with PCI Express PIO Demonstration", I encountered one recognition problem.

 

I'm using PciTree (version 2.04c) to do some test with the ML605 (Virtex-6 FPGA XC6VLX240T device), but after scan the PCIbus, the Xilinx PCI can't be found.

 

Does anyone have any idea with this problem.

 

Thanks in advance,

Fan


I suspect if there is a single reason to identify why it si not getting detected ?

 

if you had inserted the board in the slot following the guide lines mentioned in user guide and the relevant documents.

 

Can you check by rebooting the system after you program the device with .bit file.

If you still face the problem let us know.

 

Which version of Core your are using ?

 

I hope you had properly followed xtp044/45 for gnerating the core

View solution in original post

0 Kudos
Observer bamb00dark
Observer
8,355 Views
Registered: ‎07-23-2012

Re: PC can't recognize the PCIE

Jump to solution
Hi,

Thanks for everyone's help. The has been solved.

BTW, I'm using the v6_pcie_v1_7 core for the PCIe, after program the device with this core, and reboot the OS (windows 7), the pcie can be detected now.
0 Kudos