cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
vanperhieu2310
Visitor
Visitor
3,579 Views
Registered: ‎11-09-2019

Unknown header type 7f

Jump to solution

Hi, I'm working on Numato Aller Artix 7, and facing a problem when trying to build a simple project with IP DMA/Bridge Subsystem for PCIe like a figure below. After generated bitstream and program down to board, I use command lspci -v in Linux to display information about pci buses but it's show "Unknown header type 7f". How can I fix it?
Thank in advance1.PNG2.png

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
mmcnicho
Xilinx Employee
Xilinx Employee
3,497 Views
Registered: ‎10-09-2019

Hi,

This issue typically occurs when the configuration space is not accessible. 

Could you check if the link up is stable?

Thanks,

Matt 

View solution in original post

4 Replies
mmcnicho
Xilinx Employee
Xilinx Employee
3,498 Views
Registered: ‎10-09-2019

Hi,

This issue typically occurs when the configuration space is not accessible. 

Could you check if the link up is stable?

Thanks,

Matt 

View solution in original post

vanperhieu2310
Visitor
Visitor
3,462 Views
Registered: ‎11-09-2019
Hi Matt,

Thanks a lot for your help. However I'm a newbie so could you please explain more how to check link up stable?

Thanks in advance


0 Kudos
mmcnicho
Xilinx Employee
Xilinx Employee
3,419 Views
Registered: ‎10-09-2019

Hi,

I would recommend enabling the JTAG Debugger in your design use this AR as a reference.

https://www.xilinx.com/support/answers/72471.html

Let me know if this helps.

Thanks,

Matt 

vanperhieu2310
Visitor
Visitor
3,389 Views
Registered: ‎11-09-2019
HI Matt,
Thanks a lot for your help. I just realized that I assigned pcie ports wrong location that made the Header Type in BAR 0 incorrect
0 Kudos