cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
4,778 Views
Registered: ‎06-11-2009

simulation problem about pcie1.9 hurry!!

Jump to solution

hi everyone,

 

the simulation of pcie core 1.9 is link up,i can see the "trn_lnk_up_n" both of dsport and ep asserted to low.
but why the signal "trn_rd_c" in ep is not valid? all the signal about transmit of dsport is valid,such
as trn_tsof_n and trn_teof_n, but the sinal about receive of ep is not valid except for "trn_lnk_up_n".
do someone know why the problem exists??

 

i have attached the picture of signals in silulation.


i'm hurry for help!!thanks!!

signal.JPG
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Observer
Observer
5,517 Views
Registered: ‎06-11-2009
hi,
thanks for your reply. i have solved the problem ,i just used sample_smoke_test0 in "simulate_mti.do" ,
but haven't tried other tests. now i have got the correct result.

View solution in original post

0 Kudos
2 Replies
Highlighted
Anonymous
Not applicable
4,763 Views

It looks as if you are performing the transaction before trn_link_up_n is asserted.

It might be better to wait for that, then try the transaction.

 

0 Kudos
Highlighted
Observer
Observer
5,518 Views
Registered: ‎06-11-2009
hi,
thanks for your reply. i have solved the problem ,i just used sample_smoke_test0 in "simulate_mti.do" ,
but haven't tried other tests. now i have got the correct result.

View solution in original post

0 Kudos