UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
4,534 Views
Registered: ‎04-08-2009

jtag loader not working

Jump to solution

Hi,

 I am having some issues getting the jtag loader to work. I am wondering if the directory length matters or not.

I tried to run hex2svfsetup.exe from

"C:\perforce\depot\eni\eng\projects\DEV\E9319_LowPower\P00_System_FPGA\lp_control\src\uc_uart_flash\kcpsm_code"

and it did not work with the following error message

The system cannot execute the specified program.

 

but it works from

"C:\my_designs"

 

Any idea why. Thanks

Amish

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Adventurer
Adventurer
5,068 Views
Registered: ‎04-08-2009

Re: jtag loader not working

Jump to solution

Hi,

 yeah you are probably right. I eventually created a batch file and copied all files needed to c:\temp before compiling and uploading the fpga. That seems to work. Thanks for the help.

Amish

 

View solution in original post

0 Kudos
2 Replies
Advisor eilert
Advisor
4,522 Views
Registered: ‎08-14-2007

Re: jtag loader not working

Jump to solution

Hi Amish

your path has more than 100 chars and only the programmers at xilinx can tell what size they choose for the path variable buffer in their program.

 

But there's a way how you can deal with this. 

Don't use the absolute path.

A relative path from your working directory will do it as well.

e.g (as a script /batch)

 

#change path to your project directory

cd  C:\perforce\depot\eni\eng\projects\DEV\E9319_LowPower\P00_System_FPGA

#call  hex2svfsetup from here

hex2svfsetup.exe [options] .\lp_control\src\uc_uart_flash\kcpsm_code\yourcode.hex

 

So the path is reduced to 55 chars. Hope this wors, otherwise you can go deeper with cd and start the tool there.

 

Have a nice synthesis

  Eilert

 

0 Kudos
Highlighted
Adventurer
Adventurer
5,069 Views
Registered: ‎04-08-2009

Re: jtag loader not working

Jump to solution

Hi,

 yeah you are probably right. I eventually created a batch file and copied all files needed to c:\temp before compiling and uploading the fpga. That seems to work. Thanks for the help.

Amish

 

View solution in original post

0 Kudos