cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
tiago0297
Adventurer
Adventurer
921 Views
Registered: ‎03-22-2018

Can't initialize AXI DMA

Jump to solution

 Hi

 

I'm new to Vivado and this is my first project trying to access the Axi DMA. It's important for my university research, so every help is very welcome.

 

I'm making a project that I've found in a tutorial that do a convolution operation in a image. I'm trying to use the debug function of the VIvado SDK and set a breakpoint at the very end of my program. The problem is that it gets stuck and never reaches this breakpoint. So, to figure out where it's stucking, i've set som other break points and found out that it's stucking in the XAxiDma_CfgInitialize(&axiDma, CfgPtr) operation of my int initDMA(), never returning. 

 

I'm using Vivado 2017.2 and ZedBoard. If anyone have some suggestion, i'll be very happy. I'm attaching my SDK files.

 

Thanks

0 Kudos
1 Solution

Accepted Solutions
tiago0297
Adventurer
Adventurer
820 Views
Registered: ‎03-22-2018

I think I solved the problem. Not sure how, but when I runned Program FPGA again it initialized de AXI DMA.

 

I'll mark this as a solution, but now my project is stucking at XDoimgproc_Write_kernel_Bytes().

View solution in original post

0 Kudos
4 Replies
johnvivm
Voyager
Voyager
903 Views
Registered: ‎08-16-2018

Could you share your hw design as well, for the problem could be in the hardware?

 

 

0 Kudos
tiago0297
Adventurer
Adventurer
900 Views
Registered: ‎03-22-2018

Yes, of course. I've edited the main post with the Vivado Project File.

Is it enough? I've tryied to upload all the files but it exceeds the size limit.

0 Kudos
tiago0297
Adventurer
Adventurer
849 Views
Registered: ‎03-22-2018

I'm sorry for directly replying in this topic, but I'd like to know if anyone found some answear to my problem?

 

I've passed my day trying to figure it out, but without success :/

0 Kudos
tiago0297
Adventurer
Adventurer
821 Views
Registered: ‎03-22-2018

I think I solved the problem. Not sure how, but when I runned Program FPGA again it initialized de AXI DMA.

 

I'll mark this as a solution, but now my project is stucking at XDoimgproc_Write_kernel_Bytes().

View solution in original post

0 Kudos