cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ronnywebers
Advisor
Advisor
13,450 Views
Registered: ‎10-10-2014

IP_Flow 19-3158 - FREQ_HZ bus parameter missing from AXI interface when interface is not associated to a clock

I've created and packaged a custom IP which has 2 master and 2 slave axis ports. To save on clock pins in the IP symbol, in my VHDL source, I've shared the axis_aclk and axis_aresetn signals for the 4 interfaces.

 

* I get a warning for each of the 4 axis ports, saying i.e. for the s00_axis interface:

 

[IP_Flow 19-3158] Bus Interface 's00_axis': FREQ_HZ bus parameter missing from AXI interface when interface is not associated to a clock.

 

* to create the axis interfaces from the signal, I had to select the signals (i.e. s00_axis_tdata, s00_axis_tlast, s00_axis_tvalid and s00_axis_tready), then right click 'auto-infer interface' -> select axis. Here's the result :

 

freq_hz.jpg

 

 

 

Q1 : I would expect that these interfaces are inferred automatically by the IP packager (?) Or is not possible for the tool because I shared the axis_aclk and axis_aresetn signal among the 4 ports?

 

From the warning I get, I think to understand that I have to tell IP packager which signal represents the axi clock, this is in my case axis_aclk. I guess this is needed for timing analysis?

 

Q2 : how can I do this?

 

-> i,e, if I right click on s00_axis I can select 'Associate clocks ...' this pops up the following dialog which only allows me to click ok, but nothing happens. I would expect I could select axis_aclk from a list?

 

freq_hz1.jpg

 

-> I can also right-click, then select 'edit interface', and add the 'FREQ_HZ' parameter in the 3rd tab (parameters)

 

freq_hz2.jpg

 

Q3: the warning disappears, but this seems very strange to me since I don't see how the signal axis_aclk is now associated with the s00_axis interface? I just added this parameter, but nothing about the axis_aclk signal

 

Q4 : what with the axis_aresetn signal? do I have to associate this in a similar way with a bus parameter?

 

 

** kudo if the answer was helpful. Accept as solution if your question is answered **
0 Kudos
1 Reply
gmarinkovic
Explorer
Explorer
9,349 Views
Registered: ‎01-09-2012

Hello Ronny,

 

I just faced the same problem but fortunately the right click on s00_axis I can select 'Associate clocks ...'

In 2016.2 this looks like follows in my case:

Capture.JPG

 

Then the warning is gone. However I agree with you: Why can't the tool do this automatically... especially if only one clock is used.

 

Cheers

Goran