cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
11,594 Views
Registered: ‎10-22-2015

MicroBlaze and 10GE

Hello,

I'm looking into integrating 10G Ethernet with the MicroBlaze on the VC709 development board. I'm only planning to run a slow RPC service on the MicroBlaze, so the 10Gigabit speed is needed due to 10G Aurora running on the same MGT Quad. I'm planning to use the AXI 10GE Subsystem, DMA and AXIS interconnect cores. The AXIS interconnects are expected to be used for rate/width conversion between the MicroBlaze (32-bit @ 100MHz) and the 10GE subsystem (64-bit @ 156.25MHz).  

Is this possible with exisiting xilkernel drivers (Vivado 2015.2)? I assuming the lwIP driver is my only option.

Is the reference project "xapp1026" the best reference design for this effort?

 

Any additional advise would be appreciated.

 

Thanks!

0 Kudos
4 Replies
Highlighted
Contributor
Contributor
10,484 Views
Registered: ‎10-22-2015

Re: MicroBlaze and 10GE

Does the xilKernel support the 10G Ethernet Subsystem (v3.0)?

 

Are there any design approaches to running the AXI 1G/2.5G Ethernet Subsystem on a pre-configured 10G Aurora 64B/66B MGT bank?

0 Kudos
Highlighted
Observer
Observer
4,348 Views
Registered: ‎09-10-2016

Re: MicroBlaze and 10GE

Hi

Any update on using LWIP and 10gb subsystem?

0 Kudos
Highlighted
Observer
Observer
1,904 Views
Registered: ‎09-10-2016

Re: MicroBlaze and 10GE

up!!!

0 Kudos
Highlighted
Adventurer
Adventurer
320 Views
Registered: ‎10-17-2018

Re: MicroBlaze and 10GE

The driver support in accord to https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842485/Linux+AXI+Ethernet+driver has been implemented only on 2017.1.

0 Kudos