cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
1,690 Views
Registered: ‎09-21-2010

Upgrade to ISE/XPS 12.3 causing issues

Hi all,

 

I just upgraded from version 12.1 to 12.3 of the ISE suite.  I transferred my 12.1 ISE project over to 12.3 and updated it, and made a brand new microblaze processor in XPS 12.3, to get around the problems with superseded cores.  Now when I synthesize my design, I get the following warnings:


WARNING:Xst:1474 - Core <proc_sys_reset_0_wrapper> was not loaded for <proc_sys_reset_0> as one or more ports did not line up with component declaration.  Declared output port <Interconnect_aresetn<0>> was not found in the core.  Please make sure that component declaration ports are consistent with the core ports including direction and bus-naming conventions.
WARNING:Xst:1474 - Core <microblaze_0_wrapper> was not loaded for <microblaze_0> as one or more ports did not line up with component declaration.  Declared input port <M_AXI_IP_BID<0>> was not found in the core.  Please make sure that component declaration ports are consistent with the core ports including direction and bus-naming conventions.
WARNING:Xst:1474 - Core <mdm_0_wrapper> was not loaded for <mdm_0> as one or more ports did not line up with component declaration.  Declared input port <S_AXI_AWADDR<31>> was not found in the core.  Please make sure that component declaration ports are consistent with the core ports including direction and bus-naming conventions.

 

I set up my processor to use the old PLB bus standard, not AXI, so I don't know why these are being included.  I suppose I could get into the code and try to remove them manually, but that would be a pain.  If I finish the whole compilation process and program the board, my UART does not work properly; it can send characters but cannot receive them (using XUartLite_RecvByte).  How can I solve this?

0 Kudos
0 Replies