cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
timo-ge
Explorer
Explorer
3,664 Views
Registered: ‎11-12-2007

xc7z012s not supported?

Jump to solution

Hi, 

I am trying to build my project for the Zynq 7012S device, coming from a 7015.

 

I have a microblaze in the block design and the ELF fo it is directly loaded into bram wehen creating the boot image. I was using update_mem for this task. The command ist:

 

update_mem -meminfo out/hw/system.mmi -data out/sw/mb/mb.elf -proc bd/design_1_i/hier_microblaze_1/microblaze_1 -bit out/hw/system.bit -out out/hw/download.bit -force

 

Now, when selecting the Zynq 7012S I get the error:

ERROR: [Updatemem 57-44] xc7z012s device is not supported by update_mem.

 

I did try the brand new Vivado 2016.4 (updated from 2016.3) but same issue. 

 

 

 

0 Kudos
1 Solution

Accepted Solutions
pratham
Scholar
Scholar
6,248 Views
Registered: ‎06-05-2013

@timo-ge CR-966473 is filed on this. This will be fixed in the next vivado release.

Please note other newly added ZYNQ parts are also in need of updatemem support

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
5 Replies
pratham
Scholar
Scholar
3,419 Views
Registered: ‎06-05-2013

@timo-ge I will file a CR on this and update you.

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
pratham
Scholar
Scholar
6,249 Views
Registered: ‎06-05-2013

@timo-ge CR-966473 is filed on this. This will be fixed in the next vivado release.

Please note other newly added ZYNQ parts are also in need of updatemem support

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
timo-ge
Explorer
Explorer
3,381 Views
Registered: ‎11-12-2007

Thank you. I hope there are no other commandline tools affected.

0 Kudos
timo-ge
Explorer
Explorer
3,326 Views
Registered: ‎11-12-2007

@pratham

Do you know, if there will be a hotfix for 2016.4?

I think it will take some time until the next release (2017.1?)

0 Kudos
pratham
Scholar
Scholar
3,259 Views
Registered: ‎06-05-2013

@timo-ge Sorry, it would be in 2017.1 release.

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos