UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer yunusy
Observer
4,527 Views
Registered: ‎03-13-2014

QSPI Booting and SWI exception problem

Hİ all;

My application, which has semihosting,  runs without problem when I use JTAG boot. 

Now I create an Boot image with the Template FSBL project + my application's elf file and program it into the FLASH.

 

When I power on the Zynq 702 board with QSPI boot mode, it takes a SWI exception( or SVC) and this is the problem.

According to my observations, everything is at where they should be, e.g My application, my exception handlers etc, simply it successfully boots but somehow it takes an SWI exception somewhere. What can be the reason of this problem? How can I learn the source of problem?

 

* I put an debug point at SWI handler while on JTAG boot but it is never executed but it is executed when QSPI booting.

  

0 Kudos
1 Reply
Community Manager
Community Manager
4,519 Views
Registered: ‎07-23-2012

Re: QSPI Booting and SWI exception problem

Can you please share the boot log here?

Also you can refer to http://www.xilinx.com/support/answers/59174.html
-----------------------------------------------------------------------------------------------
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.
0 Kudos