UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer mattfel
Observer
765 Views
Registered: ‎08-09-2017

Setting PL Clock Freq in Linux on ZCU102

Hi.  I'm trying to figure out how to change the PL clock frequencies on the ZCU102 in Petalinux.  I know that on the ZC706, you can make the drivers visible by doing something like:

cd /sys/devices/amba.0/f8007000.ps7-dev-cfg
echo fclk0 > fclk_export
cd /sys/devices/amba.0/f8007000.ps7-dev-cfg/fclk/fclk0
echo 1 > set_rate

 

But I can't seem to find the equivalent steps anywhere for the ZCU102.  I found some things that seem related in /sys/devices/platform/amba/ but there only seem to be 2 clocks there, and only one clock in /sys/devices/platform/amba_pl/, and I was expecting to see 4 pl clocks.  I've enabled the clocks and set their freqs on the ultrascale ps in the Vivado block diagram gui but they seem to be physically stuck at the default 100MHz until I do something with the drivers in Linux.  

 

Thanks.

0 Kudos
1 Reply
Highlighted
283 Views
Registered: ‎03-12-2019

Re: Setting PL Clock Freq in Linux on ZCU102

In version older than 2019.1, you will have to manually enable fclk<0-3> in the devicetree. For some reasons, they are disabled by default.

In 2019.1, they are enabled by default now. So you can do the same step as described.

0 Kudos