cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer
Observer
781 Views
Registered: ‎11-07-2017

XADC XsysMon_CfgInitialize

Jump to solution

Hi,

 

I am trying to use XADC in my application. I designed the hardware and exported it to SDK. I build the code successfully but while running the code it stucks at XSysMon_CfgInitialize function. On debugging, I found the application calls DataAbortInterrupt. I am using Zybo board and 2016.4 Vivado and SDK version. I found this question on the following link too but unfortunately it is unanswered. 

https://forums.xilinx.com/xlnx/board/crawl_message?board.id=EMBEDDED&message.id=17253

 

Please find attached my hardware design, address editor tab and code 

 

Thanks & Regards

Vishav

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Observer
Observer
1,058 Views
Registered: ‎11-07-2017

Re: XADC XsysMon_CfgInitialize

Jump to solution

Hi,

 

I figured it out. I did not enable AXI4Stream in the hardware design. I thought it would be enabled by default by Vivado. Here is the screenshot.

 

Regards

Vishav

View solution in original post

Enable_AXIStream.png
0 Kudos
2 Replies
Highlighted
Moderator
Moderator
746 Views
Registered: ‎04-18-2011

Re: XADC XsysMon_CfgInitialize

Jump to solution

I've never used the Zybo board. 

I have used other HW and had no issues with the CfgInitialize in this case. 

 

Are you sure that there is no problem with the XADC? is it running as expected. 

If is out of reset and are you seeing EOC/EOS coming out of it. 

 

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Observer
Observer
1,059 Views
Registered: ‎11-07-2017

Re: XADC XsysMon_CfgInitialize

Jump to solution

Hi,

 

I figured it out. I did not enable AXI4Stream in the hardware design. I thought it would be enabled by default by Vivado. Here is the screenshot.

 

Regards

Vishav

View solution in original post

Enable_AXIStream.png
0 Kudos