cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
588 Views
Registered: ‎05-23-2017

Change the -optimization_level' configuration:

Here is the output of the vivado_hls.log

I wonder how to change the default efforts to the highest effort?

What should I add in the makefile?

INFO: [SYN 201-201] Setting up clock 'default' with a period of 3.33333ns.
INFO: [HLS 200-435] Setting 'config_sdx -optimization_level' configuration: config_rtl -vivado_phys_opt=none
INFO: [HLS 200-435] Setting 'config_sdx -optimization_level' configuration: config_bind -effort=medium
INFO: [HLS 200-435] Setting 'config_sdx -optimization_level' configuration: config_schedule -effort=medium
0 Kudos
1 Reply
Highlighted
Xilinx Employee
Xilinx Employee
567 Views
Registered: ‎03-24-2010

Please try -O option, like -O3

Type xocc --help to get help info:

    -O [ --optimize ] arg        Optimize level: [0-3,s,quick]; default is 0

 

Regards,
brucey
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos