UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie jongsae
Newbie
980 Views
Registered: ‎09-12-2018

SDx Emulation HW Failed due to missing libdpi.so

Jump to solution

Hi, I am a newbie on the SDx tool, who's experiencing difficulty to build an empty project on it. 

 

I created an empty SDx project and created a skeleton RTL kernel using "RTL Kernel Wizard". At Vivado, I synthesized, hit the Generate RTL Kernel, and selected the Netlist option. The tool said the source code and .xo files are created. Back on SDx, I added a binary container along with the RTL kernel and run with the automatically configured argument. 

 

Now the run was terminated at the phase of "Hardware accelerator integration..." with the following errors:

ERROR: [VPL 60-399] vivado failed, please see log file for detail: '/home/user/project/Emulation-HW/binary_container_1/link/vivado/vivado.log'
ERROR: [VPL 60-806] Failed to finish platform linker
ERROR: [XOCC 60-398] vpl failed
ERROR: [XOCC 60-626] Kernel link failed to complete
ERROR: [XOCC 60-703] Failed to finish linking

I checked the /home/user/project/Emulation-HW/binary_container_1/link/vivado/vivado.log file and found the following error messages: 

ERROR: [XSIM 43-4452] Linking failed for "/home/user/project/Emulation-HW/binary_container_1/link/vivado/prj/prj.sim/sim_1/behav/xsim/libdpi.so". Please check the log files or run with "-v" option for more messages.
child process exited abnormally
while executing
"exec ./elaborate.sh"
(procedure "hw_em_common_util::generate_simulation_scripts_and_compile" line 101)
invoked from within
"hw_em_common_util::generate_simulation_scripts_and_compile $config_info"
(procedure "hw_em_util::generate_simulation_scripts_and_compile" line 2)
invoked from within
"hw_em_util::generate_simulation_scripts_and_compile $config_info"
(file "/home/user/project/Emulation-HW/binary_container_1/link/vivado/ipirun.tcl" line 202)

 

I found a thread in this forum discussing the same problem: https://forums.xilinx.com/t5/SDAccel/Vivado-failed-to-link-libdpi-so/m-p/868024#M2190

The solution there is to install libc6-dev-i386 so I did, but the solution didn't work for me. 

 

I am desperately looking for any clues that you might have. Is there anybody who had the same experience?

 

0 Kudos
1 Solution

Accepted Solutions
735 Views
Registered: ‎11-01-2018

Re: SDx Emulation HW Failed due to missing libdpi.so

Jump to solution

I lost the track on this thread. It seems that I somehow figured out and left a note that says the following:

 

https://forums.xilinx.com/t5/SDAccel/Vivado-failed-to-link-libdpi-so/m-p/868024#M2190
Install libc6-dev-i386
 - sudo apt-get install -y libc6-dev-i386

 

It seems that I resolved the issue with this. Hope this helps you too!

0 Kudos
5 Replies
Moderator
Moderator
912 Views
Registered: ‎11-04-2010

Re: SDx Emulation HW Failed due to missing libdpi.so

Jump to solution
Are you using Vivado 2018.2? What's your operating system?
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Observer remy561
Observer
890 Views
Registered: ‎06-20-2018

Re: SDx Emulation HW Failed due to missing libdpi.so

Jump to solution

Did you look in the compile.log in the directory where libdpi.so should be located? I found the solution to that other thread by looking into the errors shown there. 

0 Kudos
Contributor
Contributor
744 Views
Registered: ‎05-11-2018

Re: SDx Emulation HW Failed due to missing libdpi.so

Jump to solution

Hi, @jongsae ,

have you solved this problem ? 

I have got the same problem as yours. 

0 Kudos
736 Views
Registered: ‎11-01-2018

Re: SDx Emulation HW Failed due to missing libdpi.so

Jump to solution

I lost the track on this thread. It seems that I somehow figured out and left a note that says the following:

 

https://forums.xilinx.com/t5/SDAccel/Vivado-failed-to-link-libdpi-so/m-p/868024#M2190
Install libc6-dev-i386
 - sudo apt-get install -y libc6-dev-i386

 

It seems that I resolved the issue with this. Hope this helps you too!

0 Kudos
Visitor lvenkatesh
Visitor
666 Views
Registered: ‎05-18-2018

Re: SDx Emulation HW Failed due to missing libdpi.so

Jump to solution

Faced the same issue. After installing libx-dev-i386 the linking issue was solved.

0 Kudos