UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor wat2304
Visitor
183 Views
Registered: ‎06-28-2019

setting up the environment variables

Hello everyone,

I installed SDAccel. When I compile my code (Vector Addition example), I get the following error.

ERROR: Uncaught Exception -- ERROR: [XOCC 60-311] gcc not found. Please make sure XILINX_VIVADO_HLS is defined and points to a valid location.

Makefile:46: recipe for target 'build/zcu102_hw/vadd.xo' failed
make: *** [build/zcu102_hw/vadd.xo] Error 1

Can someone help me with setting up the environment variables?

I tried appending export XILINX_VIVADO_HLS = 1 in bashrc but it's not working.

Thank you.

0 Kudos
3 Replies
Highlighted
Xilinx Employee
Xilinx Employee
160 Views
Registered: ‎01-11-2011

Re: setting up the environment variables

Hello @wat2304, please make sure you are sourcing the settings64.sh script located inside the install area, generally /opt/Xilinx/SDx/201x.x/. This script will set up the necessary environment variables to run the tools.

-------------------------------------------------------------------------
Please don’t forget to reply, kudo, and accept as solution!
-------------------------------------------------------------------------
Visitor wat2304
Visitor
133 Views
Registered: ‎06-28-2019

Re: setting up the environment variables

Hi @kmorris,

I already have this in my bashrc.

source /opt/Xilinx/SDx/2018.2/.settings64-SDx.sh

I tried adding this

source /opt/Xilinx/SDx/2018.2/settings64.sh

I am still getting the same error.

Thanks

0 Kudos
Xilinx Employee
Xilinx Employee
124 Views
Registered: ‎01-11-2011

Re: setting up the environment variables

Hi @wat2304, could you double check and make sure you have gcc and g++ installed on your system? They should be located at /usr/bin/gcc and /usr/bin/g++. This is part of the package list for the 2018.2 SDAccel Installation (UG1238). The environment variable listed in the error should not be required as long as the system can see where these compilers are.

-------------------------------------------------------------------------
Please don’t forget to reply, kudo, and accept as solution!
-------------------------------------------------------------------------
0 Kudos