cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
441 Views
Registered: ‎02-25-2014

Error using xfopencv libraries as accelerator in zc702 board : missing soft stubs

Hello,

Trying to use the xfopencv libraries example ( gaussian filter) in my application in the zc702 board, it works successfully when I do not use accelerator in the PL.

When I toggle the GaussianBlur function to the HW, I get the following error.

Performing accelerator source linting for w0_xf_GaussianBlur
Performing pragma generation
INFO: [PragmaGen 83-3231] Successfully generated tcl script: ...
Moving function w0_xf_GaussianBlur to Programmable Logic

ERROR: [SdsCompiler 83-5019] Exiting sds++ : Error when calling '/opt/Xilinx/Vivado/2017.4/bin/vivado_hls ...Debug/_sds/vhls/w0_xf_GaussianBlur_run.tcl -l w0_xf_GaussianBlur_vivado_hls.log'

 I get this error in the log file .. fatal error: 'gnu/stubs-soft.h' file not foundI
# include <gnu/stubs-soft.h>
          ^

The stubs-soft file is missing in the gnu folder of the sysroot. I read many threads about this issue and I tried the following steps but it is not working:

 

1- I added the following flags to the compiler sdscc "mcpu=cortex-a9 -mfpu=vfpv3-mfloat-abi=hard "but nothing change : these flags are only working for bare metal application ..

2- I tried to add the soft stubs file to the sysroot using the petalinux environment but I could not find it : i think it makes sense not to use the soft stubs option when you have already the floating point unit in the arm processor. 

So how can I implement successfully  some functions of the xfopencv libraries as accelerators in the PL ?

Thank you.

 

 

0 Kudos
0 Replies