We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Participant stefanoribes
Registered: ‎07-25-2016

Getting started with OpenCL on SDSoC (ZC702)

Hi everyone,


I've recently started using SDSoC with the 60-days free license. My target is to run OpenCL applications on my ZC702 board (on my Ubuntu 16.04 machine). I've downloaded the examples from the SDSoC_Examples, and tried to run hello_vadd_ocl project.


When I run the Makefile I get this error message. The tool seems complaining about my license:

Building Target: build/zcu102_es2_ocl_hw/vadd.xo
/opt/Xilinx/SDx/2017.2/bin/xocc -t hw --platform zcu102_es2_ocl --save-temps  --clkid 0 -c -k vadd --messageDb build/zcu102_es2_ocl_hw/vadd.mdb -I"src" --xp misc:solution_name=_xocc_compile_vadd -o"build/zcu102_es2_ocl_hw/vadd.xo" "src/vadd.cl"

****** xocc v2017.2_sdx (64-bit)
  **** SW Build 1972098 on Wed Aug 23 11:34:38 MDT 2017
    ** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.

Attempting to get a license: ap_opencl
WARNING: [XOCC 17-301] Failed to get a license for 'ap_opencl'. Explanation: The license server does not support feature ap_opencl. The feature has expired (on the server), or has not yet started, or the version is greater than the highest supported version.
Resolution: Check the status of your licenses in the Vivado License Manager. For debug help search Xilinx Support for "Licensing FAQ". 
ERROR: Uncaught Exception -- ERROR: [XOCC 60-400] Failed to get a license: ap_opencl

Makefile:41: recipe for target 'build/zcu102_es2_ocl_hw/vadd.xo' failed
make: *** [build/zcu102_es2_ocl_hw/vadd.xo] Error 1

However, if I check License Manager, I see 'ap_opencl_soc', not 'ap_opencl'. Are they related? Does this matter at all? (I left unchanged the target platform, but it should work anyhow, right?)


Aside question: apart from running scripts, is there any guide to run OpenCL in the GUI or a step-by-step procedure I can look at? Perhaps specifically intended for SDSoC and not SDAccel?


Thanks, Best,



0 Kudos
2 Replies
Registered: ‎09-19-2017

Re: Getting started with OpenCL on SDSoC (ZC702)

Hi Stefano,

Im not sure about the licensing problem, but I think only the MPSoC devices on zcu102 board are currently supported for OpenCL.

It might be easier for you to just request an SDAccel license to get around this issue.

0 Kudos
Visitor awiegersma
Registered: ‎10-22-2017

Re: Getting started with OpenCL on SDSoC (ZC702)

I'm having exactly the same problem and the same error messages. Is there a solution yet?

0 Kudos