UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer 3dpeter
Observer
164 Views
Registered: ‎06-06-2018

Unable to start the TCF profiler

Hi,

Sorry if this question should not be posted in this forum. I'm using SDx 2018.2, and not sure if SDK also has TCF profiler so maybe I can get the answer here.

Here is my question:

In page 12 of UG1235 SDSoC profiling and optimization guide, it states to start the TCF profiler, click the green Start button at the top of the TCF profiler tab.

TCF_profiler2.jpg

 

However, the start button is grayed out on my TCF profiler tab. Any help would be appreciated.

TCF_profiler.jpg

0 Kudos
2 Replies
Observer 3dpeter
Observer
119 Views
Registered: ‎06-06-2018

Re: Unable to start the TCF profiler

Hi,

I found when entering debug mode with “launch on hardware” successfully, the TCF profiling button is shown and can be clicked without any issue. However, if “launch on hardware” failed, the TCF profiling button is grayed out. In below screenshot there are two applications, lab 6 can launch on hardware successfully and the other one showed Linux Agent disconnected issue. Because the hardware cables connection are the same for 2 applications, I am wondering what the reason is to cause Linux Agent disconnected. Thank you in advance!

TCF_profiler5.jpg

0 Kudos
Observer 3dpeter
Observer
109 Views
Registered: ‎06-06-2018

Re: Unable to start the TCF profiler

Hi,

Lab 6 is standalone OS, and the other application is linux OS. Now the remaining question is what makes Linux Agent disconnected while launching on hardware in debug mode. Thanks.

0 Kudos