UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor muneet
Visitor
173 Views
Registered: ‎06-18-2018

7-Series GTX Data Alignment Issue

Hi,

I am using 7-series GTX generated using Kintex-7 XC7K325T. Following configuration is used: -

1. CPLL is used for Clocking,

2. 8B/10B as well as comma alignment are disabled and data is being given in the 8b/10b encoded format,

3. GTX Common Reset Block is bypassed.

In Simulation when the GTX Tx and Rx are being loopbacked then it is working fine. But when Tx and Rx of different GTX are being used, then code error and disparity errors are coming randomly.

Thank You,

Muneet

0 Kudos
2 Replies
Explorer
Explorer
86 Views
Registered: ‎03-16-2019

Re: 7-Series GTX Data Alignment Issue

you need comma alignment for aligning data between transceivers.

tell us about the clock issues of two GTs. 

Moderator
Moderator
66 Views
Registered: ‎07-30-2007

Re: 7-Series GTX Data Alignment Issue

Without comma alignment the serial to parallel converter has no way to frame the data properly.  While it might randomly work in loopback it is never gauranteed.  You need 8B10B or 64B66B to be able to do alignment.  You should consider using a canned protocol like Aurora that will take care of these issues for you.




----------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution
----------------------------------------------------------------------------