UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
474 Views
Registered: ‎05-29-2018

7z015 GTP SFP not work

Jump to solution

hi ,I  currently  have designed a board for the 7Z015 .using GTP interface to SFP .  

1.I connect the ETH interface of PS through EMIO mode. then used IP “1.5G/2G eth pcs/pma or SGMII ".this IP output SFP, I connect it directly to GTP interface, but the network has been impassable, can not find the reason.

 

2.In hardware design, we use two SFPs, that is, two optical ports, SFPA and SFPB.The 125M clock of GTP is generated by an external crystal oscillator. The power supply MGTAVCC is 1.2V. MGTAVTT is 1.0V

3.i_mgt is 125M, which is directly connected by the crystal oscillator described above. Independent CLK bufg of two IP is 200M, which is output by FCLK1 on PS side.

4.Phy_address is set to 0 and signal_detector is set to 1.

please check my design1.png2.png3.png4.png5.png6.png

 

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
441 Views
Registered: ‎07-30-2007

Re: 7z015 GTP SFP not work

Jump to solution

There is sometimes an enable port on SFP that can be overlooked.  Also check that your PLL*PD is getting set low.

Roy


----------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution
----------------------------------------------------------------------------


0 Kudos
3 Replies
Moderator
Moderator
442 Views
Registered: ‎07-30-2007

Re: 7z015 GTP SFP not work

Jump to solution

There is sometimes an enable port on SFP that can be overlooked.  Also check that your PLL*PD is getting set low.

Roy


----------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution
----------------------------------------------------------------------------


0 Kudos
Contributor
Contributor
426 Views
Registered: ‎05-29-2018

Re: 7z015 GTP SFP not work

Jump to solution

Hi,Roy.  I have set net sfp_tx_disable to "0" in my bd design,also connect  the pin to GND  in my harware PCB. 

I used only IBERT 7 series GTP ip  to test my 7015 GTP interface wherther work  normal or not.  I create links and add 4 channels  X0Y0 X0Y1 X0Y2 X0Y3 to my link groups,then do internal loopback test.But  the result shows that  my GTP work unnormal ,some channels can not pass the test.  Even I click IBERT reset,it can not normal , I must click TX reset and RX reset some times ,then it work normal and pass the loopback test.result.png 

0 Kudos
Contributor
Contributor
260 Views
Registered: ‎05-29-2018

Re: 7z015 GTP SFP not work

Jump to solution

My problem has been solved. The hardware PCB package reverses SFP's TX and rx.

0 Kudos