UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor flydrive
Visitor
747 Views
Registered: ‎09-10-2016

PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

I'm using GTYs on a Virtex Ultrascale+ module. I'm not using any of the modules' processing blocks, no buffer, no gearbox, no comma detection, just raw 32bit passthrough of the data off the wire. I've used the gt transceiver wizard to configure all this, all works fine. 

I'd like to be able to use RXSLIDE to drop one bit to help in bitstream alignment. I want to use PMA mode because that as far as I can tell has zero latency and just drops one bit and shifts the RX clock phase by 1UI. 

However I can't find anywhere in the wizard to configure this. The only place I can find RXSLIDE mentioned at all is under the 10B/8B engine, which I'm not using, and the only value you can set it to there is PCS mode, which I don't want. (It makes sense to me because if you are using the 10B/8B you'd have to slide in the PCS module so I can understand why only that setting is allowed in that block)

Is there anywhere else in that wizard that allows me to configure RXSLIDE to PMA mode and have the signal routed out of the module for my use? Is there another way to do this or do I really have to take the entire customisation and then go and add the signals in by hand? 

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
659 Views
Registered: ‎08-07-2007

Re: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

hi @flydrive

 

I think you may need to enable RX buffer in Wizard GUI if you want to use RXSLIDE PMA mode.

As you know, RXSLIDE PMA mode is changing the phase of RXOUTCLK. RX Buffer bypass circuit is also changing the RXOUTCLK phase.

So, to avoid confliction, you need to enable RX Buffer, then the Wizard GUI will allow you to select PMA in Manual Alignment drop-list.

 

Well, I agree the information in the user guide should put together everything you need to do.

Below is the step.

set the following attribute either from GUI if available or by RTL edit

RXSLIDE_MODE = PMA

RXOUTCLKSEL = 3'b010 (RXOUTCLKPMA)

RX_XCLK_SEL= “RXDES”

RXPCOMMAALIGNEN = 0;
RXMCOMMAALIGNEN = 0;
RXCOMMADETEN = 1;
SHOW_REALIGN_COMMA = FALSE

RXOUTCLK to clock RXUSRCLK/RXUSRCLK2

After RXRESETDONE goes high, assert RXSLIDE for two RXUSRCLK2 cycles and wait for at least 32 RXUSRCLK2 cycles, look at the RXDATA and see if it is shifted.

 

Thanks,

Boris

 

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
10 Replies
Xilinx Employee
Xilinx Employee
721 Views
Registered: ‎06-02-2017

回复: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

Hi flydrive,

Please refer to UG576, Chpater 4-->RX Byte and word alignment --> Manual Alignment, this section describes the usage of the RXSLIDE to complete word alignment by user logic(I think that's what you want). 

 

-------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
--------------------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Xilinx Employee
Xilinx Employee
719 Views
Registered: ‎08-25-2010

Re: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

Hi @flydrive,

 

This option can be selected on comma on receiver comma detection, on page optional features page. You can see manual alignment(RX slide) mode there.

 

 

Thanks
Simon
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor flydrive
Visitor
712 Views
Registered: ‎09-10-2016

回复: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

Yes I've read the transceiver guide and I know what RXSLIDE mode does and that I want to use it - my question was about how to set PMA RXSLIDE mode using the gt wizard, if that's even possible, and if it's not possible, how to do it. 

0 Kudos
Visitor flydrive
Visitor
711 Views
Registered: ‎09-10-2016

Re: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

I put in my original question that the only place I can see RXSLIDE mode is on the comma detection. However, as I said then

1) I'm not using 10B/8B mode nor comma detection

2) That dropdown box ONLY allows for PCS RXSLIDE and I said I wanted PMA mode. So it doesn't work. 

 

I appreciate that people reply but I do wish they'd actually read the question properly first, all this information was in there. 

0 Kudos
Xilinx Employee
Xilinx Employee
702 Views
Registered: ‎08-25-2010

Re: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

Which vivado version do you use?

I can see the PMA RXSLIDE in the dropdown box:

 

 

Thanks
Simon
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
rxslide.PNG
0 Kudos
Visitor flydrive
Visitor
696 Views
Registered: ‎09-10-2016

Re: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

ok I can't, I have "Off" and "PCS" only. Is there a combination of other options I have elsewhere which might make PMA unavailable? I've read the documentation a few times and don't see what might disable PMA mode, however I don't have that choice (nor Automatic PMA either). 

This is wizard v1.7 by the way, in case that helps. The Basic page is set up for 10.3125Gb/s, raw encoding, 32/32, buffer bypass on both TX and RX. I'm using all the channels in X0Y7. 

Any option combinations you can think of which would be incompatible with RXSLIDE PMA mode and so the wizard removes it as an option? 

 

0 Kudos
Xilinx Employee
Xilinx Employee
682 Views
Registered: ‎08-25-2010

Re: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

When RXSLIDE_MODE = PMA is used, the RX recovered clock phase (RXOUTCLK when RXOUTCLKSEL =  3'b010  and XCLK when RX_XCLK_SEL= “RXDES”) is shifted by 2 UI for every alternate RXSLIDE pulse. So this need RX Buffer enable to fix the phase difference.

Thanks
Simon
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor flydrive
Visitor
677 Views
Registered: ‎09-10-2016

Re: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

let me go read that bit of the documentation again then. I see what you're saying, however I don't actually care about the RX clock phase, I'm not aligning it with anything, I don't have channels bonded etc, so the fact the phase moves 1UI when I slip one bit (which I was probably going to do exactly once whist getting synched) doesn't really matter. 

In fact that's the effect I actually wanted. I wanted to assert RXSLIDE (PMA), have the SIPO drop one single bit giving me one very slightly long RX clock cycle and then continue. I don't need to fix the phase difference, I can quite happily live with it. 

0 Kudos
Xilinx Employee
Xilinx Employee
660 Views
Registered: ‎08-07-2007

Re: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

hi @flydrive

 

I think you may need to enable RX buffer in Wizard GUI if you want to use RXSLIDE PMA mode.

As you know, RXSLIDE PMA mode is changing the phase of RXOUTCLK. RX Buffer bypass circuit is also changing the RXOUTCLK phase.

So, to avoid confliction, you need to enable RX Buffer, then the Wizard GUI will allow you to select PMA in Manual Alignment drop-list.

 

Well, I agree the information in the user guide should put together everything you need to do.

Below is the step.

set the following attribute either from GUI if available or by RTL edit

RXSLIDE_MODE = PMA

RXOUTCLKSEL = 3'b010 (RXOUTCLKPMA)

RX_XCLK_SEL= “RXDES”

RXPCOMMAALIGNEN = 0;
RXMCOMMAALIGNEN = 0;
RXCOMMADETEN = 1;
SHOW_REALIGN_COMMA = FALSE

RXOUTCLK to clock RXUSRCLK/RXUSRCLK2

After RXRESETDONE goes high, assert RXSLIDE for two RXUSRCLK2 cycles and wait for at least 32 RXUSRCLK2 cycles, look at the RXDATA and see if it is shifted.

 

Thanks,

Boris

 

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Visitor flydrive
Visitor
644 Views
Registered: ‎09-10-2016

Re: PMA RXSLIDE mode on a GTY using the gtwizard

Jump to solution

@borisq thank you - that answer completes the picture. I hadn't realised that RX Buffer Bypass also changed the RXOUTCLK phase but that makes sense looking at the documentation yet again. So I can't have full raw bypass and use RXSLIDE. 

I checked the online latency documentation about the GTY and as far as I can tell the RX buffer will introduce more than I can spare so I'll deal with the bit alignment in logic and give up on the RXSLIDE idea. 

Thanks for the help and discussion. I understand the clocking domains in the GTY a little better now also which is helpful. 

 

0 Kudos