cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
DiamondBound
Observer
Observer
541 Views
Registered: ‎03-18-2020

Another ERROR:Compxlib - COMPXLIB[sim] problem

Jump to solution

Hi Xilinx people!

I've resurrected an old project and had to install ISE 14.7 and was able to build the project without problems. But I'm now trying to simulate and I've run into this  ERROR:Compxlib:267 problem. I've made sure that all the solutions are applied but still see the error, any ideas?? Using modelsim PE. My error is copied below. I'm wondering if the problem is related to the fact that I already have vivado installed on this laptop? I've re-posted this under a separate thread because I don't have the 267 in error massage: ERROR:Compxlib:267 - COMPXLIB" 

--Ross

C:\Xilinx\14.7\ISE_DS\ISE\bin\nt64\unwrapped\compxlib.exe -s mti_pe -l verilog -dir C:/************************************************_fpga/sim/work/work -p C:/modelsim_dlx64_2019.4/win64pe -arch spartan6 -lib unisim -lib simprim -lib xilinxcorelib -lib
edk -exclude_superseded -intstyle ise
------------------------------------------------------------------------------
ERROR:Compxlib - COMPXLIB[sim]: Unable to automatically find executables for simulator 'mti_pe' from the following paths:
C:/modelsim_dlx64_2019.4/win64pe
C:\Xilinx\14.7\ISE_DS\ISE\\lib\nt64
C:\Xilinx\14.7\ISE_DS\ISE\\bin\nt64
C:\Xilinx\14.7\ISE_DS\ISE\bin\nt64
C:\Xilinx\14.7\ISE_DS\ISE\lib\nt64
C:\Xilinx\14.7\ISE_DS\ISE\..\..\..\DocNav
C:\Xilinx\14.7\ISE_DS\PlanAhead\bin
C:\Xilinx\14.7\ISE_DS\EDK\bin\nt64
C:\Xilinx\14.7\ISE_DS\EDK\lib\nt64
C:\Xilinx\14.7\ISE_DS\EDK\gnu\microblaze\nt\bin
C:\Xilinx\14.7\ISE_DS\EDK\gnu\powerpc-eabi\nt\bin
C:\Xilinx\14.7\ISE_DS\EDK\gnuwin\bin
C:\Xilinx\14.7\ISE_DS\EDK\gnu\arm\nt\bin
C:\Xilinx\14.7\ISE_DS\EDK\gnu\microblaze\linux_toolchain\nt64_be\bin
C:\Xilinx\14.7\ISE_DS\EDK\gnu\microblaze\linux_toolchain\nt64_le\bin
C:\Xilinx\14.7\ISE_DS\common\bin\nt64
C:\Xilinx\14.7\ISE_DS\common\lib\nt64
C:\Program Files (x86)\Common Files\Oracle\Java\javapath
C:\windows\system32
C:\windows
C:\windows\System32\Wbem
C:\windows\System32\WindowsPowerShell\v1.0\
C:\windows\System32\OpenSSH\
C:\Program Files (x86)\Webex\Webex\Applications
C:\Program Files\Intel\WiFi\bin\
C:\Program Files\Common Files\Intel\WirelessCommon\
C:\modelsim_dlx64_2019.4\win64pe\vsim.exe
C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL
C:\Program Files\Intel\Intel(R) Management Engine Components\DAL
C:\Program Files\PuTTY\
C:\Users\C62310\AppData\Local\Microsoft\WindowsApps.
Simulator 'mti_pe' is ignored.

 

1) I've made sure that the Model Tech Simulator field in Edit => Preferences => ISE General => Integrated Tools has the correct path to your ModelSim executable (in my case, it is "C:\modeltech_pe_6.5d\win32pe\modelsim.exe")

2) I've made sure that under Project > Design Properties that you have the right simulator selected in the Simulator field (in my case, it was Modelsim-PE verilog).

3) I've made sure that my PATH environment variable is correctly pointing to modelsim dir.

4) I only have one simulator installed MTI.

I think the real problem is this:

Snip…

   C:\modelsim_dlx64_2019.4\win64pe\vsim.exe  <-----

Snip….

The tool added vsim.exe to the correct path and is treating that as a path. And BTW vsim is incorrect it should be vlog.

0 Kudos
1 Solution

Accepted Solutions
DiamondBound
Observer
Observer
516 Views
Registered: ‎03-18-2020

 

We finally figured this out after 10 hours of suffering!!!!

In the Design Utilities right click "Compile HDL Sim..." to view the Process Prop - General Options the very first switch name is -s Target Sim 

Turns out you DO NOT WANT to select modelsim PE for the simulator even if that's what you are using!

YOU MUST CHOOSE Modelsim-DE Verilog

--Ross

View solution in original post

0 Kudos
1 Reply
DiamondBound
Observer
Observer
517 Views
Registered: ‎03-18-2020

 

We finally figured this out after 10 hours of suffering!!!!

In the Design Utilities right click "Compile HDL Sim..." to view the Process Prop - General Options the very first switch name is -s Target Sim 

Turns out you DO NOT WANT to select modelsim PE for the simulator even if that's what you are using!

YOU MUST CHOOSE Modelsim-DE Verilog

--Ross

View solution in original post

0 Kudos