UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor nothing1234
Visitor
10,037 Views
Registered: ‎06-24-2012

Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

Hy , I have Modelsim 6.6 SE 6.6d.

I am trying to follow the example from ISE in-depth since I'm new to this.

 

I am trying to 'connect' the ISE to ModelSim by using Compxlib commandfrom ISE Design Suite Command Prompt.

My command for the ISE command promt : compxlib -s mti_se -l verilog -p C:\modeltech_6.6d\win32\modelsim.exe -lib C:/Xilinx/12.3/ISE_DS/ISE/ISEexamples/wtut_ver

 

But I got this error:(attached Command promt error*)

 

FYI,

My ModelSim folder : C:\modeltech_6.6d\win32\modelsim.exe

My project folder : C:/Xilinx/12.3/ISE_DS/ISE/ISEexamples/wtut_ver

 

FYI, I have read some solved problem : http://forums.xilinx.com/t5/Simulation-and-Verification/ModelSim-Failed-to-get-the-pre-compiled-simulation-library/td-p/120586 , that's why I have changed my process properties' "Compiled Library Directory" but it doesn't solve my problem.

 

Can anyone help me?

 

Thank you in Advance :)

command_promt_error.jpg
0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
12,779 Views
Registered: ‎11-28-2007

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

You reset the PATH in your command window. I suggest you open "ISE Design Suite Command Prompt" window and then run "vsim" from there. If it works that means modelsim is in your PATH. If it doesn't you will need to append it to your PATH , not re-set it.

 


@nothing1234 wrote:

Hy Jim,

I want to make sure which way of setting environment variable do you talking about ?

By using System Properties : yes, I have set them (attached pic)

By using run>cmd : i have tried with no success (attached pic), maybe I dont know how to set them by using cmd

 

FYI, I'm runnning 64-bit windows 7 OS, is it matters?

 

Please help ~

Thank you in advance :)

 

cmd_fail.jpgEnvi_Param.jpg




Cheers,
Jim

View solution in original post

0 Kudos
10 Replies
Visitor nothing1234
Visitor
10,036 Views
Registered: ‎06-24-2012

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

Continued~

process_prop.jpg
0 Kudos
Xilinx Employee
Xilinx Employee
10,029 Views
Registered: ‎11-28-2007

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

Do you have "C:\modeltech_6.6d\win32" in your PATH environment variable?

 

Please check the AR below on how to set up environment variables:

 

http://www.xilinx.com/support/answers/11630.htm

 

 

 


@nothing1234 wrote:

Hy , I have Modelsim 6.6 SE 6.6d.

I am trying to follow the example from ISE in-depth since I'm new to this.

 

I am trying to 'connect' the ISE to ModelSim by using Compxlib commandfrom ISE Design Suite Command Prompt.

My command for the ISE command promt : compxlib -s mti_se -l verilog -p C:\modeltech_6.6d\win32\modelsim.exe -lib C:/Xilinx/12.3/ISE_DS/ISE/ISEexamples/wtut_ver

 

But I got this error:(attached Command promt error*)

 

FYI,

My ModelSim folder : C:\modeltech_6.6d\win32\modelsim.exe

My project folder : C:/Xilinx/12.3/ISE_DS/ISE/ISEexamples/wtut_ver

 

FYI, I have read some solved problem : http://forums.xilinx.com/t5/Simulation-and-Verification/ModelSim-Failed-to-get-the-pre-compiled-simulation-library/td-p/120586 , that's why I have changed my process properties' "Compiled Library Directory" but it doesn't solve my problem.

 

Can anyone help me?

 

Thank you in Advance :)




Cheers,
Jim
0 Kudos
Visitor nothing1234
Visitor
10,024 Views
Registered: ‎06-24-2012

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

Hy Jim,

I want to make sure which way of setting environment variable do you talking about ?

By using System Properties : yes, I have set them (attached pic)

By using run>cmd : i have tried with no success (attached pic), maybe I dont know how to set them by using cmd

 

FYI, I'm runnning 64-bit windows 7 OS, is it matters?

 

Please help ~

Thank you in advance :)

 

cmd_fail.jpgEnvi_Param.jpg

0 Kudos
Xilinx Employee
Xilinx Employee
10,015 Views
Registered: ‎04-16-2012

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

Hi

 

To add environmental variable (as suggested by Jim), follow below steps (as per your snapshots):

 

1. In "User variables"of Environmental variables window, select PATH environmental variable and click on edit

2. Now add ";C:\modeltech_6.6d\win32" in variable value field without inverted commas.

 

Thanks.

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Xilinx Employee
Xilinx Employee
12,780 Views
Registered: ‎11-28-2007

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

You reset the PATH in your command window. I suggest you open "ISE Design Suite Command Prompt" window and then run "vsim" from there. If it works that means modelsim is in your PATH. If it doesn't you will need to append it to your PATH , not re-set it.

 


@nothing1234 wrote:

Hy Jim,

I want to make sure which way of setting environment variable do you talking about ?

By using System Properties : yes, I have set them (attached pic)

By using run>cmd : i have tried with no success (attached pic), maybe I dont know how to set them by using cmd

 

FYI, I'm runnning 64-bit windows 7 OS, is it matters?

 

Please help ~

Thank you in advance :)

 

cmd_fail.jpgEnvi_Param.jpg




Cheers,
Jim

View solution in original post

0 Kudos
Visitor nothing1234
Visitor
10,003 Views
Registered: ‎06-24-2012

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

Hy Jim and vuppala, thank you for your reply.

I have set everything like below pic:

changing_PATH_failed.jpg

 

I can run the vsim.exe and this command too.

Command: compxlib -s mti_se -l verilog -p C:\modeltech_6.6d\win32\modelsim.exe -lib C:/Xilinx/12.3/ISE_DS/ISE/ISEexamples/wtut_ver and got below result:

 

ISE Command Prompt:

ISE_command_promp_1.jpg

(continued..)

ISE_command_promp_2.jpg

(continued..)

ISE_command_promp_3.jpg

 

But I still cant find out where the "modelsim.ini" anywhere in the output directory : C:\Xilinx\12.3\ISE_DS\ISE.

I think I need this modelsim.ini to "linking" this ISE with ModelSim , is it right?

Any suggestion ?

 

Thank you in advance :)

0 Kudos
Xilinx Employee
Xilinx Employee
10,000 Views
Registered: ‎11-28-2007

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

Look for modelsim.ini in C:\Xilinx\12.3\ISE_DS, the directory you launch compxlib from.

 

Yes, you will need the memory mappings in modelsim.ini for modelsim to work with the newly compiled library.

Cheers,
Jim
0 Kudos
Visitor nothing1234
Visitor
9,934 Views
Registered: ‎06-24-2012

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

Thank you ywu and vuppala,

   Sorry for the late reply, since I can't find out any modelsim.ini in that path. So I give up linking ISE with Modelsim, since I can run the Modelsim only (without linking them).

  But nearly, I found out that the Modelsim doesn't consider any delay when simulating. EG:

code:

 

always @(posedge clk or negedge rst_n)

begin

  if(!rst_n) reg_temp <= 2'b00;

  else   reg_temp <= 2'b01;

end

 

always @(posedge clk)

   reg <= reg_temp;

end

 

From above code, logically , the value of "reg" will appear 1 clk later than "reg_temp". Correct me if I am wrong.

But I can't from get any delayed like in the attached picture from the modelsim. (reg and reg_temp change at the same time).

reg_temp.jpg

That's why now I try to link ISE with ModelSim again, to see if I can get the delayed(real) simulation result.

By using the last command I "magically" succeed to create modelsim.ini in the targeted directory. But I get below error message when I double clicking the "Simulate Post-Place & Route Model" at ISE.

modelsim_work_error.jpg

 

FYI , I have tried to compile all of the files from the IS first, but got below error :

ISE_compile_error.jpg

Can anybody help me ?

Thank you in advance
Yuyex

0 Kudos
Xilinx Employee
Xilinx Employee
9,918 Views
Registered: ‎07-16-2008

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

For the (vsim-19) error when launching modelsim from ISE, this is a known issue with Modelsim/Questa 6.6d/10.0.

Please refer to Xilinx Answer 39961.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor nothing1234
Visitor
3,136 Views
Registered: ‎06-24-2012

Re: Compxlib Problem : Simulator "mti_se" is ignored

Jump to solution

Thank you Grace .. I got the modelsim working done.

I haven't got the expected delay for that "reg" and "reg_temp" though :( .

 

Yuyex

0 Kudos