cancel
Showing results for 
Search instead for 
Did you mean: 
245 Views
Registered: ‎02-04-2020

ERROR: [Vivado 12-3754] Failed to find the 'questasim' simulator executable. Vivado 2019.2

Cannot compile simulation libraries.  I have done this a dozen times before... now it will no longer work after I installed 2019.2... not even when I try with my still installed 2019.1.3.

In my PATH environment variable I have: c:\questasim64_10.6c\win64

If I open a command window and type > questasim... it opens questasim.

When in 2019.2 I select "Compile Simulation Libraries" and enter:

Simulator: Questa Advanced Simulator

Language: All

Library: All

Family: All but Versal

Compiled library location: C:/SimLibs_Vivado19_2_Questa10_6c

Simulator executable path: C:/questasim64_10.6c/win64

Complie Xilinx IP: checked

Overwrite the current pre-compiled libraries: checked

Verbose: checked

I get the following tcl command:

compile_simlib -simulator questa -simulator_exec_path {C:/questasim64_10.6c/win64} -family kintex7 -family virtex7 -family artix7 -family spartan7 -family zynq -family kintexu -family kintexuplus -family virtexu -family virtexuplus -family zynquplus -language all -library all -dir {C:/SimLibs_Vivado19_2_Questa10_6c} -force -verbose

I then get error:

ERROR: [Vivado 12-3754] Failed to find the 'questasim' simulator executable. Make sure to set the 'questasim' installation environment and retry this command to compile the libraries for this simulator. For more information on tool setup refer 'questasim' user guide.
Library compilation for 'questasim' ignored.
compile_simlib: Time (s): cpu = 00:01:13 ; elapsed = 00:01:17 . Memory (MB): peak = 1018.242 ; gain = 321.207
ERROR: [Common 17-39] 'compile_simlib' failed due to earlier errors.

In the tcl console:

which questasim

C:\questasim64_10.6c\win64\questasim.EXE

exec questasim  (lauches questasim)

Un-installed and Re-installed 19.2_1106_2127... still no good.

I have read through other similar forum posts... i haven't found one with a "this is how I fixed it"

Any thoughts?  Thank you

0 Kudos
1 Reply
Highlighted
192 Views
Registered: ‎02-04-2020

Re: ERROR: [Vivado 12-3754] Failed to find the 'questasim' simulator executable. Vivado 2019.2

Turns out IT recently implemented user privilege blocking software.  I don't fully understand why this stops the ability to generate the libraries... but it did.   I was able to disable the blocking software and successfully build the libraries.  Thank you, Ken

0 Kudos