UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
11,981 Views
Registered: ‎02-18-2013

Error - Wavedata 42-52

Jump to solution

Hello,

 

I got this error everytime when I start a simulation:

 

Error.png

 

How can I fix this problem?

 

Thank you for help!

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
21,284 Views
Registered: ‎04-16-2012

Re: Error - Wavedata 42-52

Jump to solution
Hello,

If that is the case, try below steps:

1. In Project sources window, are you observing the VG_Ctrl.wcfg file?
2. If yes, right click on it and select disable file
3. Run simulation

Thanks,
Vinay
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.

View solution in original post

Tags (1)
0 Kudos
9 Replies
Xilinx Employee
Xilinx Employee
11,968 Views
Registered: ‎04-16-2012

Re: Error - Wavedata 42-52

Jump to solution

Hello,

 

The error messsage clearly indicates that VGA_Ctrl.wcfg is already open.

Close the simulation window and rerun the simulation.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Explorer
Explorer
11,962 Views
Registered: ‎02-18-2013

Re: Error - Wavedata 42-52

Jump to solution

Thank you. I have tried this before, but it doesn´t solve the problem :(

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
21,285 Views
Registered: ‎04-16-2012

Re: Error - Wavedata 42-52

Jump to solution
Hello,

If that is the case, try below steps:

1. In Project sources window, are you observing the VG_Ctrl.wcfg file?
2. If yes, right click on it and select disable file
3. Run simulation

Thanks,
Vinay
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.

View solution in original post

Tags (1)
0 Kudos
Visitor paulatvti
Visitor
11,593 Views
Registered: ‎04-09-2014

Re: Error - Wavedata 42-52

Jump to solution

I had the same error.  To fix this problem, I closed down Vivado, manually deleted all of the wcfg files, then re-opened the project and removed the wcfg files (that Vivado can not find since I deleted them) from the project.  This worked for me.

0 Kudos
Adventurer
Adventurer
11,438 Views
Registered: ‎03-05-2008

Re: Error - Wavedata 42-52

Jump to solution

I've had a similar problem ... repeated attempts to open the same wcfg file, ... and I tried getting rid of it by removing the reference to it from Vivado Project Manager Sources window. When this didn't work I tried the suggestion above and deleted all wcfg files from the project folder and below ...

 

... but the tool now complains about the missing files.

 

WARNING: [USF-XSim-17] WCFG file does not exist:C:/project/attic_packed_samples/sim/attic_packed_samples_wrap_TB_behav.wcfg
WARNING: [USF-XSim-17] WCFG file does not exist:C:/project/attic_packed_samples/sim/attic_packed_samples_wrap_TB_behav.wcfg
WARNING: [USF-XSim-17] WCFG file does not exist:C:/project/attic_packed_samples/sim/attic_packed_samples_wrap_TB_behav.wcfg
WARNING: [USF-XSim-17] WCFG file does not exist:C:/project/attic_packed_samples/sim/attic_packed_samples_wrap_TB_behav.wcfg
WARNING: [USF-XSim-17] WCFG file does not exist:C:/project/attic_packed_samples/sim/attic_packed_samples_wrap_TB_behav.wcfg
WARNING: [USF-XSim-17] WCFG file does not exist:C:/project/attic_packed_samples/sim/attic_packed_samples_wrap_TB_behav.wcfg

 

Can anyone help, please

PaulD

0 Kudos
Xilinx Employee
Xilinx Employee
11,426 Views
Registered: ‎07-16-2008

Re: Error - Wavedata 42-52

Jump to solution

Did you set option "-view <file path>/attic_packed_samples_wrap_TB_behav.wcfg" in xsim.simulate.xsim.more_options field?

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
11,419 Views
Registered: ‎03-05-2008

Re: Error - Wavedata 42-52

Jump to solution

Hi graces,

 

Thanks for your suggestion. I've looked and there are no entries in the xsim.simulate.xsim.more_options field.

So I've editted the project .xpr file directly to remove the two duplicate lines in the section shown:

 

      <Config>
        <Option Name="DesignMode" Val="RTL"/>
        <Option Name="TopModule" Val="attic_packed_samples_wrap_TB"/>
        <Option Name="TopLib" Val="xil_defaultlib"/>
        <Option Name="TopAutoSet" Val="TRUE"/>
        <Option Name="SrcSet" Val="sources_1"/>
        <Option Name="XSimWcfgFile" Val="$PPRDIR/sim/attic_packed_samples_wrap_TB_behav.wcfg"/>
        <Option Name="XSimWcfgFile" Val="$PPRDIR/sim/attic_packed_samples_wrap_TB_behav.wcfg"/>
        <Option Name="XSimWcfgFile" Val="$PPRDIR/sim/attic_packed_samples_wrap_TB_behav.wcfg"/>
      </Config>

 

 

... and this cures the problem!

 

PaulD

0 Kudos
Newbie mikecwilk
Newbie
10,834 Views
Registered: ‎08-01-2015

Re: Error - Wavedata 42-52

Jump to solution

Thanks prdorrell,

 

This is the correct answer just edit the project .xpr file. Hopefully it is fixed in 2014.5. Im still using 2014.4.

 

0 Kudos
Adventurer
Adventurer
10,719 Views
Registered: ‎03-05-2008

Re: Error - Wavedata 42-52

Jump to solution
Hi mikecwilk, I'm glad my hacking workaround has helped some else ... My post was from earlier this year when I still used Vivado 2014.3. Since then, I've upgraded to 2015.1 ... and haven't seen this problem again ... so maybe Xlinx have fixed it. Kind regard prdorrell
0 Kudos