UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer frivera
Observer
7,334 Views
Registered: ‎02-23-2016

[USF-XSim 62] 'elaborate' step failed with error(s) while executing '.../sim_1/behav/elaborate.bat' script

The complete message received is:

 

[USF-XSim 62] 'elaborate' step failed with error(s) while executing 'C:/Xilinx/Projects/Vivado2016_3/Correlator_OOC/Correlator_OOC.sim/sim_1/behav/elaborate.bat' script. Please check that the file has the correct 'read/write/execute' permissions and the Tcl console output for any other possible errors or warnings.

 

The issue is produced not all the time but lately is becoming permanent when I start Behavioral Simulation. The issue is present using Vivado 2016.2 and also with the new version 2016.3. I am enclosing the following files: compile.log, elaborate.log and xvlog.log. My design is working, I can synthesize, implement and generate bitstream. Even I can program my Nexys4 board. I need to make some changes so the simulation is very important for me in this moment. I will appreciate any comment.

 

Thanks and regards,

frivera

0 Kudos
7 Replies
Xilinx Employee
Xilinx Employee
7,320 Views
Registered: ‎10-24-2013

Re: [USF-XSim 62] 'elaborate' step failed with error(s) while executing '.../sim_1/behav/elaborate.bat' script

Hi @frivera

1) Try deleting the xsim.dir under your simulation folder.

2) If that doesnt help, try creating a fresh project and see if that helps.

Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Teacher muzaffer
Teacher
7,311 Views
Registered: ‎03-31-2012

Re: [USF-XSim 62] 'elaborate' step failed with error(s) while executing '.../sim_1/behav/elaborate.bat' script

It seems all commands pass but the "xsim.dir/Correlator_Top_tb_behav/obj" directory can't be removed for some reason. Try to delete that directory and see if it helps.
- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
0 Kudos
Observer frivera
Observer
7,276 Views
Registered: ‎02-23-2016

Re: [USF-XSim 62] 'elaborate' step failed with error(s) while executing '.../sim_1/behav/elaborate.bat' script

I tried both options but the problem remains. The issue started working with Vivado 2016.2 and continued creating a fresh project in the new Vivado version 2016.3. I think the problem has to do with Windows. By the way, I am working with Windows 8.1 Pro 64-bits.

 

Regards,

 

0 Kudos
Observer frivera
Observer
7,209 Views
Registered: ‎02-23-2016

Re: [USF-XSim 62] 'elaborate' step failed with error(s) while executing '.../sim_1/behav/elaborate.bat' script

Hi @vijayak

 

Do you have any new idea for solving this problem?. I have tried your indication but the problem remains. The simulation (Behavioral Simulation) works once every 10 intents. As you can imagine it is very annoying to work this way. Do you recommend to use ModelSim instead?. I will appreciate any comment about.

 

Regards,

frivera 

0 Kudos
Highlighted
Observer frivera
Observer
4,171 Views
Registered: ‎02-23-2016

Re: [USF-XSim 62] 'elaborate' step failed with error(s) while executing '.../sim_1/behav/elaborate.bat' script

I am retaken my original post after 9 months now. As everybody can realize I still have the problem and Xilinx has no solution. According  to my original post the problem started when I was using 2016.2 VIVADO version. After that I have being using versions 2016.3, 2016.4, 2017.1 and now I am using 2017.2 version and the problem remains. I am sure now that the problem appears regardless the project you are working with; it is something between VIVADO and Windows. By the way, I am using Windows 8.1 Pro 64 bits. The only way to avoid the problem (but it does not work all the time) is restarting the computer. I ask to Xilinx guys, is there any possibility to really solve this problem?; I have tried all the indications you have delivered in the Forum but they do not work. If I not receive any answer I am thinking seriously to move my design to Intel FPGA (former ALTERA).

 

Regards,

frivera

0 Kudos
Teacher muzaffer
Teacher
4,163 Views
Registered: ‎03-31-2012

Re: [USF-XSim 62] 'elaborate' step failed with error(s) while executing '.../sim_1/behav/elaborate.bat' script

@frivera can you try a different version of windows to see if it makes a difference? windows 10 is significantly better than windows 8.

- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
0 Kudos
Observer frivera
Observer
4,114 Views
Registered: ‎02-23-2016

Re: [USF-XSim 62] 'elaborate' step failed with error(s) while executing '.../sim_1/behav/elaborate.bat' script

Thanks Teacher for your answer. Unfortunately I do not have the possibility to try a different version of Windows. By the way, I have seen users posts that have reported this problem using different Windows versions like Windows 7. I do not believe that using Windows 10 the problem will be solved. I think it is a serious VIVADO problem that Xilinx should face seriously.

 

Regards,

frivera

0 Kudos