cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
9,447 Views
Registered: ‎03-07-2015

Unable to automatically find executables for simulator 'mti_se'

I am trying to compile libraries but I am getting following error:

Signature:-
------------------------------------------------------------------------------
compxlib -s mti_se -p C:\altera\14.1\modelsim_ase\win32aloem\modelsim.exe -l vhdl -arch all -lib all -w -exclude_superseded
------------------------------------------------------------------------------
ERROR:Compxlib - COMPXLIB[sim]: Unable to automatically find executables for simulator 'mti_se' from the following paths:
C:\altera\14.1\modelsim_ase\win32aloem
E:\Xilinx\14.5\ISE_DS\ISE\\lib\nt
E:\Xilinx\14.5\ISE_DS\ISE\\bin\nt
E:\Xilinx\14.5\ISE_DS\ISE\bin\nt
E:\Xilinx\14.5\ISE_DS\ISE\lib\nt
E:\Xilinx\14.5\ISE_DS\ISE\..\..\..\DocNav
E:\Xilinx\14.5\ISE_DS\PlanAhead\bin
E:\Xilinx\14.5\ISE_DS\EDK\bin\nt
E:\Xilinx\14.5\ISE_DS\EDK\lib\nt
E:\Xilinx\14.5\ISE_DS\EDK\gnu\microblaze\nt\bin
E:\Xilinx\14.5\ISE_DS\EDK\gnu\powerpc-eabi\nt\bin
E:\Xilinx\14.5\ISE_DS\EDK\gnuwin\bin
E:\Xilinx\14.5\ISE_DS\EDK\gnu\arm\nt\bin
E:\Xilinx\14.5\ISE_DS\EDK\gnu\microblaze\linux_toolchain\nt_be\bin
E:\Xilinx\14.5\ISE_DS\EDK\gnu\microblaze\linux_toolchain\nt_le\bin
E:\Xilinx\14.5\ISE_DS\common\bin\nt
E:\Xilinx\14.5\ISE_DS\common\lib\nt
C:\altera\14.1\modelsim_ase\win32aloem
C:\Modeltech_eval_5.7f\win32
C:\Modeltech_5.7f\win32.
Simulator 'mti_se' is ignored.

 

I have modelsim 10.3c installed in this directory: C:\altera\14.1\modelsim_ase\win32aloem\modelsim.exe

I have this path set to modeltech simulator: C:\altera\14.1\modelsim_ase\win32aloem\modelsim.exe

I have this simulator in project's properties: ModelSim -SE VHDL

I have set the variable path too.

 

I have tried every solution but it is still giving error.

0 Kudos
4 Replies
Highlighted
Xilinx Employee
Xilinx Employee
9,420 Views
Registered: ‎09-20-2012

Re: Unable to automatically find executables for simulator 'mti_se'

Hi,

In Edit-->Preferences set the path to modelsim as C:\altera\14.1\modelsim_ase\win32aloem and see if it helps.

Also under project--> design properties did you set the simulator field to right one?

Refer to this thread for a similar issue http://forums.xilinx.com/t5/Installation-and-Licensing/Problem-with-compxlib/td-p/66413

Thanks,
Deepika.
Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos
Highlighted
Visitor
Visitor
9,413 Views
Registered: ‎03-07-2015

Re: Unable to automatically find executables for simulator 'mti_se'

I am still getting the error. The path in  compile hdl simulation libraries is same as path of modelsim. And by changing the path of compiler to C:\altera\14.1\modelsim_ase\win32aloem, still error is coming.

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
9,385 Views
Registered: ‎07-16-2008

Re: Unable to automatically find executables for simulator 'mti_se'

Is it a standard Modelsim SE edition of a custom edition with Altera tool? I see it's installed under Altera directory.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Adventurer
Adventurer
360 Views
Registered: ‎03-31-2017

Re: Unable to automatically find executables for simulator 'mti_se'

Yes, 2019, but still very relevant...

I'm pretty sure that compxlib (either stand-alone or through the ISE GUI) actually checks the ModelSim version. In your case, it finds that it's dealing with ModelSim Altera 10.6d, and gives up. Xilinx: this is a really bad call - 10.6d is 10.6d, and it really doesn't matter if it is an Altera distribution. And, of course, you haven't done a ModelSim XE since 11.1, I think, which was a long time ago, and the Altera one works great.

This is how to debug the problem, and all the other compxlib failures on the forums:

  1. find 'Compile HDL simulator libraries' on the ISE GUI, right-click, and select 'process properties'
  2. On the -p option, navigate to the directory that contains vcom.exe/vlog.exe/etc. This means that you don't need to rely on any PATH variables
  3. Under 'other command line options', add '-verbose'
  4. Run, check the log in the GUI, confirm that compxlib could run vcom.exe or vlog.exe
  5. Look further up the file for the Current Working Directory (CWD)
  6. Note that the log file ran 'vlog.exe -version' and saved the output to a log file in the CWD. Go to the cwd, get the output from this file

What I'm surmising is that the file output has to match in some way with the 'target simulator' option in the 'process properties' dialog, and it doesn't, so end of game.

Anyone else coming this way could try downloading an old precompiled 11.x library, which may or may not work with ISE 14.7.

Note that Vivado's compile_simlib does correctly generate 32-bit libraries for Altera's free ModelSim - I've done this on Linux and it works well.

 

 

0 Kudos