cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
naeim35
Visitor
Visitor
1,099 Views
Registered: ‎03-12-2018

Vivado 2017.4 Modelsim verification License issue

Hi all,

 

I try to use ModelSim PE Simulator instead of the default Vivado Simulator. I have created a TestBench which includes the AXI VIPs blocks using Vivado 2017.4 . When I run the simulation including the DUT the ModelSim simulator runs but I encounter with this Error:

....

# Loading xilinx_vip.axi_vip_if_sv_unit
# Loading xilinx_vip.axi_vip_if
# Loading xilinx_vip.axi_vip_axi4pc
# Loading work.gash_axi_vip_1_0
# ** Error: (vsim-1) Unable to checkout verification license - testbench generation feature (randomize, randcase, randsequence, covergroup) is only supported with QuestaSim.
#    Time: 0 ps  Iteration: 0  Instance: /gash_tb File: ../../../../gash_tb.srcs/sources_1/new/gash_tb.sv
# Error loading design
# Error: Error loading design
#        Pausing macro execution
# MACRO ./gash_tb_simulate.do PAUSED at line 9

...

 

My question is that if ModelSim PE 10.5a supports AXI VIPs? Is there any solution for this problem?

 

Best regards,

 

Naeim

0 Kudos
1 Reply
amaccre
Moderator
Moderator
1,088 Views
Registered: ‎04-24-2013

HI @naeim35,

 

You need to use ModeSim 10.6b or later with Vivado 2017.4.

 

This is documented in User Guide 973

 

Capture1.PNG

 

Vivado is very specific about which versions or third party tools are supported as there are frequent additions and updates of IP.

 

Best Regards
Aidan

------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if this answered your question
Give Kudos to a post which you think is helpful and may help other users
------------------------------------------------------------------------------------------------------------------
0 Kudos