cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
s002wjhw
Voyager
Voyager
2,357 Views
Registered: ‎06-26-2015

hardware manager ila init error

after open hardware manager I sometime get these errors?  note I have jesd204 in the design? not sure its a timing or something. I also has petalinux 2017.2 on the 706 board.

 

 

Untitled.jpg

0 Kudos
2 Replies
thakurr
Moderator
Moderator
2,315 Views
Registered: ‎09-15-2016

Hi @s002wjhw

 

There are few things to check here.

1) Is the timing meeting? You can run report_timing_summary on the implemented design, and see if it is met.

2) As suggested in the error's resolution, see  the board connectivity to the hardware target whether it is being detected or not.

3) Also make sure your ILA clock is free running clock and JTAG frequency is half or less than half to your ILA frequency.

 

Hope this helps.

 

Regards

Rohit

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

Regards
Rohit
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

0 Kudos
travisc
Moderator
Moderator
2,264 Views
Registered: ‎10-19-2011

The majority of the time i see this error the problem is the clock not being active/free running. Were is the clock coming from? If its from the PS side, make sure that the clock is active first (ps7_init). Below is a link to another forum post on how to setup the clock from the ps.

https://forums.xilinx.com/t5/Design-Tools-Others/ILA-core-not-recognized-by-hardware-manager/td-p/552554

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------