cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie
Newbie
7,357 Views
Registered: ‎09-25-2015

waveform configuration automatic when simulating

Jump to solution

Hello, I have create a waveform configuration file.

I would like to simulate with that waveform configuration file automatically.

 

Currently I am:

1. running simualtion use the default configuration

2. opening the custom waveform configuaration file, I want

3. Restarting the simuation 

4. running the simulation.

 

thanks

daniel

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
14,008 Views
Registered: ‎02-14-2014

Re: waveform configuration automatic when simulating

Jump to solution

Hello @dgamma,

 

Which version of Vivado are you using? I have tried these steps with Vivado version 2015.2 and I get the pop-up as seen in the snapshot below 

 

Capture.PNG

 

You can also add this file to your project using below Tcl commands. Type these commands after you save .wcfg file -

 

add_files -fileset sim_1 -norecurse C:/Users/daniel/Documents/_Uni/CSSE4010/project_1/test_behav3.wcfg
set_property xsim.view C:/Users/daniel/Documents/_Uni/CSSE4010/project_1/test_behav3.wcfg [get_filesets sim_1]

close_sim

 

Now close the project and simulate it after re-opening. Hope this helps.

 

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
6 Replies
Highlighted
Xilinx Employee
Xilinx Employee
7,350 Views
Registered: ‎02-14-2014

Re: waveform configuration automatic when simulating

Jump to solution

Hello @dgamma,

 

You can achieve this by adding Waveform configuration file to your project. To do this, you need to follow below steps -

 

1. Select File -> Save Waveform Configuration As

2. You will be asked to add this file to project with pop-up. Click Yes.

3. This adds .wcfg file to your project with its absolute path. 

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Newbie
Newbie
7,339 Views
Registered: ‎09-25-2015

Re: waveform configuration automatic when simulating

Jump to solution

Hi Ashish,

 

thanks so much for your help.

I do not get the pop up box. you mentioned.

The TCL outputs after the save of the waveform: 

save_wave_config {C:/Users/daniel/Documents/_Uni/CSSE4010/project_1/test_behav3.wcfg}

but no pop-up is displayed, asking if I would like to add the file to the project.

 

thanks

daniel

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
14,009 Views
Registered: ‎02-14-2014

Re: waveform configuration automatic when simulating

Jump to solution

Hello @dgamma,

 

Which version of Vivado are you using? I have tried these steps with Vivado version 2015.2 and I get the pop-up as seen in the snapshot below 

 

Capture.PNG

 

You can also add this file to your project using below Tcl commands. Type these commands after you save .wcfg file -

 

add_files -fileset sim_1 -norecurse C:/Users/daniel/Documents/_Uni/CSSE4010/project_1/test_behav3.wcfg
set_property xsim.view C:/Users/daniel/Documents/_Uni/CSSE4010/project_1/test_behav3.wcfg [get_filesets sim_1]

close_sim

 

Now close the project and simulate it after re-opening. Hope this helps.

 

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
Highlighted
Newbie
Newbie
7,316 Views
Registered: ‎09-25-2015

Re: waveform configuration automatic when simulating

Jump to solution

Hello @ashishd,

 

thank you so much mate! - it worked!

 

I think I know why, I am not seeing this dialog box, I probably clicked "Dont show this dialog again" button, when I first used this program, and didn't understand what it meant.

 

Is it now possible, to reset the  "Dont show this dialog again" box, so I can this option again? (I googled but couldn't find an answer)

 

thanks

daniel

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
7,306 Views
Registered: ‎02-14-2014

Re: waveform configuration automatic when simulating

Jump to solution

Hello @dgamma,

 

Surely there is a way to re-enable this. You need to follow below steps -

 

1. Launch Vivado GUI and navigate to Tools -> Window Behavior

2. Check the option 'Ask before adding waveform configuration file (wcfg) to project. You can refer below snapshot -

 

Capture.PNG

 

 

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
7,284 Views
Registered: ‎02-14-2014

Re: waveform configuration automatic when simulating

Jump to solution

Hello @dgamma,

 

Did that help? Feel free to close the thread by marking helpful post as solution.

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos