UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor jahiltner
Visitor
212 Views
Registered: ‎02-10-2016

xvlog hangs with no output

when I run behavioral simulation on my project, normally it takes about 10min to compile and elaborate.

I fixed a few compile errors, then on the next compile, xvlog hangs with no tcl console output, I let it run for 2 hours.

I added the -verbose 2 option, and only get library map dumps before it hangs.

I'm working on modifying a kcu105 ug919 demo project in vivado 2017.3.

Are there any other xvlog options I can turn on?

0 Kudos
3 Replies
Moderator
Moderator
188 Views
Registered: ‎09-15-2016

Re: xvlog hangs with no output

Hi @jahiltner,

Can you please share the archived project and the compile.log file to check this issue at our end.

Thanks & Regards,
Sravanthi B
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Visitor jahiltner
Visitor
169 Views
Registered: ‎02-10-2016

Re: xvlog hangs with no output

It's a 500MB project, so I removed .runs and .sim before zipping it.

I forgot to save the sim log, so I re-ran sim.

From a clean sim node, it ran correctly and dumped errors.

I should have thought of that. Clean nodes have solved problems in the past for me.

0 Kudos
Visitor jahiltner
Visitor
151 Views
Registered: ‎02-10-2016

Re: xvlog hangs with no output

I have to clean the node for every run or it hangs.

the project zip file is over 300MB, too big to post.

console output with a clean node error report and then a hang is attached.

other sim logs too.

0 Kudos