cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sha@hys
Explorer
Explorer
6,716 Views
Registered: ‎05-31-2015

Xilinx platform cable USB JTAG chain detection failed

Hello,

 

  I was using xilinx platform cable USB 2 previously for many days in my windows 7 ultimate system. It was working properly. Now I switched to a desktop with windows 7 professional. Now when I plug in the debug cable in chipscope as I try to connect i get:

ERROR:No devices detected while scanning the JTAG chain
ERROR: Failed detecting JTAG device chain
ERROR: Opened Xilinx Platform USB Cable but failed to detect JTAG Chain.

In impact as I try to initialize chain I get:

A problem may exist in the hardware configuration. check that cable, scan chain and power connections are intact ,that specified scan chain configuration matches actual harware and that power supply is adequate and delivering correct voltage.

 

I checked in device drivers that Jungo driver installed properly. Also I tried reinstalling from ug344_windows.zip. But error persist.  I think this relates to change in operating system. There is some missing dll or something for chipscope in this system. Suggest me some remedy.

 

Earlier I opened a query on same topic in Xilinx at below link:

https://forums.xilinx.com/t5/Spartan-Family-FPGAs/JTAG-chain-detection-failed-in-xilinx-platform-cable-USB/td-p/749504

 

I got a solution then , I tried reinstalling the drivers and when I plugged in it was working then. Afterwards till yesterday I was in some other work did not use cable. Yesterday when I plugged in same error repeats and I tried doing steps in previous solution (reinstalling jungo drivers) many times . Still not effective . Suggest me a permanent solution

 

With regards

Shalini

0 Kudos
10 Replies
kkn
Moderator
Moderator
6,701 Views
Registered: ‎01-15-2008

Hi Shalini,

check if any other peripheral in your system is trying to access the jungo driver which is required by the programming cable

is it possible for you to re-install the OS in your windows 7 prof system and then try 

--Krishna

0 Kudos
sha@hys
Explorer
Explorer
6,685 Views
Registered: ‎05-31-2015

Hello,

My system is only using same set of peripherals as in previous case and no peripheral use Jungo driver. Also I have tried reinstalling windows 7 once. Again same issue happens. If the solution worked well and cables were detected 2 weeks back, why not now ? Can it be a problem with my cable?

With Regards

Shalini

0 Kudos
kkn
Moderator
Moderator
6,683 Views
Registered: ‎01-15-2008

you can try to check the cable on different machine which it worked earlier.

what's the colour of the led when you connect to the system

0 Kudos
sha@hys
Explorer
Explorer
6,681 Views
Registered: ‎05-31-2015

Hello,

 

The LED is lit green itself. Sorry to say , but I cant test the cable on any other machine as now I am having a single license and single machine. No body else is working on the same software in my office. Please say if I can do any driver install , or add on to system etc.

 

With Regards

Shalini

0 Kudos
sha@hys
Explorer
Explorer
6,678 Views
Registered: ‎05-31-2015

Hello,

 

 I suspect the drivers were signed versions when it was working correctly. But now it is not signed version. Please tell me how to install signed version of jungo drivers. The drivers were detected not signed when I checked using File Signature verification tool.

 

With Regards

Shalini

0 Kudos
sha@hys
Explorer
Explorer
6,548 Views
Registered: ‎05-31-2015

Hello,

 

        My problem is not yet solved. I was trying to open a service request with Xilinx. But I am not getting option for one in site. Seems like as a user I dont have permission to open a SR with xilinx. Please tell me way to open service request with Xilinx for same.

 

With Regards

Shalini

Tags (1)
0 Kudos
vuppala
Xilinx Employee
Xilinx Employee
6,543 Views
Registered: ‎04-16-2012

Hi sha@hys

 

Try these steps:

  1. Open Command Prompt as Administrator
  2. Navigate to C:\Xilinx\14.7\ISE_DS\ISE\bin\nt64
  3. Open the folder: C:\Windows\System32\drivers
  4. Rename the windrvr6.sys to windrvr6.sys_old
  5. In Command Prompt, run the following commands:
    • wdreg -inf %cd%\windrvr6.inf uninstall
    • wdreg -inf %cd%\windrvr6.inf install
  6. Now verify whether a new windrvr6.sys file is created in the folder: C:\Windows\System32\drivers
  7. Now run iMPACT and try connecting the board using the cable.

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
sha@hys
Explorer
Explorer
6,541 Views
Registered: ‎05-31-2015

Hello,

 

   Thank you for reply. But before trying I have a doubt. Mine is 64 bit windows 7 professional. So I should do these operations in System 32 or in System 64 folder?

 

with Regards

Shalini

0 Kudos
vuppala
Xilinx Employee
Xilinx Employee
6,539 Views
Registered: ‎04-16-2012

hi sha@hys

 

Even it is 64-bit machine, use System32 folder as mentioned in my post.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
sha@hys
Explorer
Explorer
4,325 Views
Registered: ‎05-31-2015

Hello,

I tried all the steps you have mentioned. But The cable is not detected by software and same error as previously mentioned persists.

windrvr6.sys was created in the folder.

 

With Regards

Shalini

0 Kudos