UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
5,091 Views
Registered: ‎11-11-2009

spartan-3e board: platform flash prom can't configure FPGA

Hi everyone, I'm a newer to spartan-3e.

 

The problem occurs when I try to configure fpga in master serial mode:

 

My platform is ise10.1.03, using platform cable USB, xilinx platform flash is xcf04s, the mode selection pin M[2:0] is set to be 000.

 

After programming the xcf04s, iMPACT says it is programmed successfully. But when I press the PROG button to configure the spartan-3e, the DONE led is not lit and it seems the data in the platform flash is not loaded into FPGA.

 

Did anyone here once have this problem ? And how did you solve it? It haunts me like a couple days now. Thanks for your help!

Best Regard.

Ninos K.
0 Kudos
3 Replies
Visitor zm98
Visitor
5,071 Views
Registered: ‎12-18-2009

Re: spartan-3e board: platform flash prom can't configure FPGA

I got same problem now. the platform flash can not boot 3e500! I can probe to see the data present on DIN pin of FPGA but DONE pin never goes high....

Anybody has idea how to solve this kind of annoying thing???

0 Kudos
Visitor snake68
Visitor
4,270 Views
Registered: ‎05-07-2012

Re: spartan-3e board: platform flash prom can't configure FPGA

I have the exact problem with SPARTAN-3E, but my platform is ISE 13.4. I've changed the board once, it worked fine for a few days but then I faced the same issue!

0 Kudos
Highlighted
Visitor snake68
Visitor
4,267 Views
Registered: ‎05-07-2012

Re: spartan-3e board: platform flash prom can't configure FPGA

YESSSSSSSS! Found the problem!

The problem is in xc2c64a CPLD. CE (chip enable) of xcf04 platform flash is controlled by xc2c64a CPLD, but CPLD doesn't select the flash. I think if a programming procejure (in iMPACT) fails, the original CPLD design will be deleted. So I downloaded the Default Xilinx CPLD Design file from here and programmed it into my board's CPLD. Fortunately it worked without errors and now my PROM works fine when I press the PROG button.