UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor bloct1
Visitor
469 Views
Registered: ‎07-12-2018

resloved: failed to program xc3s400an internal flash,Done not gone go high!

Hello.

 

I'm using XC3S400AN and am trying to program to internal flash.

Then pins are set as follows:

 

Mode pin:  M2=0, M1=1, M0=1

VS0,1,2= : 1,1,1

Prog_B,pudc_b,init,din,dclk:  pulled high with external resistors

Done:  pulled high with external resistors by 330R (1.5K)

Suspend:  grounded

the fpga can runing by jtag but canot promgramming to internal flash

 

After programing 60% then stop on there

in console shows:

programming successful

verify successful

Configuration data download to FPGA was not successful. DONE did not go high, please check your configuration setup and spi mode settings

I've trid a lot, but I could not find what is wrong in my case.

Then, could you give me some  advises, please ? thank you very much.

 

replaced the xc3s400an_spi.cor then sloved the problem.

2 Replies
Scholar drjohnsmith
Scholar
460 Views
Registered: ‎07-09-2009

Re: failed to program xc3s400an internal flash,Done not gone go high!

what program you using to program with ?

   what OS ?

0 Kudos
Visitor bloct1
Visitor
454 Views
Registered: ‎07-12-2018

Re: failed to program xc3s400an internal flash,Done not gone go high!

ISE 14.7   win7 64   jtag

0 Kudos