cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
979 Views
Registered: ‎11-28-2017

Xst:1336 - (*) More than 100% of Device resources are used

Jump to solution

hi, I'm using SP601 board with xc6slx16-2csg324.  But I get a warning "Xst:1336 -  (*) More than 100% of Device resources are used". the Device Utilization Summary is here

SOURCE.png

The only one that over used is DCMs. But xc6slx16 should support 4 DCMs and I only used one. And the Available mount it shows is 0. That's weird. This project was programmed on Spartan 3 and I just move it to Spartan6. Could it be the cause?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
1,108 Views
Registered: ‎11-03-2016

If you are using primitive instantiation in your code and there is nothing to match it up in the other device ISE stops there (much like Vivado actually). Say you used DCM_ADV in S3, but in S6 the equivalent is named DCM_ADV2, then you have to match up the name for S6. Also check anything that was produced from CoreGen.

View solution in original post

0 Kudos
3 Replies
Highlighted
Xilinx Employee
Xilinx Employee
1,109 Views
Registered: ‎11-03-2016

If you are using primitive instantiation in your code and there is nothing to match it up in the other device ISE stops there (much like Vivado actually). Say you used DCM_ADV in S3, but in S6 the equivalent is named DCM_ADV2, then you have to match up the name for S6. Also check anything that was produced from CoreGen.

View solution in original post

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
975 Views
Registered: ‎11-03-2016
See ug382 in chapter 2 table 2-3, inS6 it's named DCM_SP.
0 Kudos
Highlighted
Visitor
Visitor
921 Views
Registered: ‎11-28-2017
thanks. I regenerated the DCM block and the problem is gone
0 Kudos