cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dcwhitehead
Adventurer
Adventurer
1,067 Views
Registered: ‎03-28-2014

Phase Sync ZCU111 to external 10MHz reference

I'm trying to use an external 10MHz reference as the input to the LMK04208 chip on the ZCU111 and have the  resulting clock be synced in phase relative to the reference clock. I've gotten to the point where I can generate a stable output off of the external 10MHz reference, but it seems like phase syncing requires using CLKin1 as a feedback clock instead of an input source.

Is there any way to do an internal feedback (instead of external) with the 0-Delay setting and have the device phase synced to the input clock?

TICS Pro .tcs file renamed to .tcs.txt due to forum restrictions....

 

dcwhitehead_0-1598286719060.png

 

0 Kudos
6 Replies
klumsde
Moderator
Moderator
916 Views
Registered: ‎04-18-2011

probably more of a question for the TI forum. 

i've used clkout5 here to synch to an external instrument before but i've not used an external input to clock this PLL.

I heard a proposal to use a 10mhz input let me check to see if i have a TicsPro profile that does this. 

Keith

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
dcwhitehead
Adventurer
Adventurer
908 Views
Registered: ‎03-28-2014

Thanks Keith.

The posted configuration will successfully take in a 10MHz reference and generate the proper clocks, but I am trying to get the clock phase synced so I can sample on two different ZCU111 boards with the same phase relationship.

Right now, every power cycle the clocks on the two boards come up with different phase relationships. I think this should be doable but still have not figured it out.
0 Kudos
krish_vamsi
Visitor
Visitor
741 Views
Registered: ‎11-25-2020

dear @dcwhitehead, am also working for the same problem. but i couldn't able to find proper solution. can you please let me know, if you get the solution.?
thanking you
0 Kudos
ptrkrysik
Visitor
Visitor
406 Views
Registered: ‎02-24-2021

Your 'R divider' and 'N divider' settings don't look right for 10MHz reference clock input. For me it seems your settings won't effect in correct synchronization to 10MHz (before even getting into phase synchronization). Check out the answer I provided here about synchronization to external 10MHz reference and see if it helps: https://forums.xilinx.com/t5/Versal-and-UltraScale/Synchronize-external-LO-with-ZCU111/td-p/1043394

0 Kudos
dcwhitehead
Adventurer
Adventurer
393 Views
Registered: ‎03-28-2014

@ptrkrysikthe R & N settings were correct for my application because the downstream PLLs are being configured to generate a 1.28GHz sample clock and this give the proper starting frequency. I still have not found good documentation on phase synchronization but have been able to put that on the back burner.

0 Kudos
ptrkrysik
Visitor
Visitor
360 Views
Registered: ‎02-24-2021

@dcwhiteheadare you able to phase synchronize tiles on single ZCU111? The documentation says that MTS (Multi-Tile Synchronization) is needed for this to work and MTS requires configuration of additional clocks. Especially SYSREF_RFSOC clock on CLKout1 of LMK04208. I haven't tried MTS myself yet.

0 Kudos