cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
379 Views
Registered: ‎07-05-2018

HDMI example Error for Si5324

Hello,

 

I am using a HDMI example of TX-only HDMI system guided in pg235 with software using Vitis.

 

It worked well a week ago, but it suddenly does not work with the error message "Error programming SI5324".

 

Does anybody can tell me where the problem come from?

 

I attached the screenshot showing the error message.

Thank you.

 

HDMI error.JPG

 

 

Tags (2)
0 Kudos
6 Replies
Highlighted
Teacher
Teacher
347 Views
Registered: ‎06-16-2013

Hi @oupps 

 

Would you refer XTP428 (Xilinx's Example Designs : Running the ZCU102 Board Interface Test) to investigate the route cause, if your board is ZCU102 ?

If other, would you refer similar BIST (Build In Self Test) tool ?

 

Best regards,

0 Kudos
Highlighted
Visitor
Visitor
327 Views
Registered: ‎08-04-2019

I am running into a similar issue. My error message is "Error programming free mode SI5324"

I was able to successfully run the BIST and verify it is not an issue with the ZCU102. I am using Vitis/Vivado 2020.1.

I was also able to get an HDMI output from the board earlier today using a different reference project. I have not seen an HDMI output from the MIPI CSI-2 RX reference design yet, just this error.

0 Kudos
Highlighted
Visitor
Visitor
314 Views
Registered: ‎07-05-2018

Thanks for your apply, @watari 

 

First, I am using VCU118 evauluation kit(version of VIVADO = 2019.2).

As you recommended, I am done the bulit-in self test following the instruction, but it does not show any problem.

Could you suggest other ways to find out the cause ?

 

Best regards,

0 Kudos
Highlighted
Visitor
Visitor
312 Views
Registered: ‎07-05-2018

Hello, 

 

In addition to the above reply, when I check the debugging process through UART and Vitis, the GT reference clock is continuously changing as follows.

 

Below figures are captured images when I input 'i', which is the information of status.

 

clk1.JPGclk2.JPGclk3.JPG

 

Best regards,

 

 

0 Kudos
Highlighted
Teacher
Teacher
235 Views
Registered: ‎06-16-2013

Hi @oupps 

 

Would you make sure SCL and SDA for Si5324 by oscilloscope on IIC ?

I suspect bus line issue on IIC...

 

Best regards,

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
182 Views
Registered: ‎08-02-2007

@oupps 

What's the revision of your ZCU102, it might be related to a known power issues :

https://www.xilinx.com/support/answers/66811.html

 

0 Kudos